locked
Strange behaviour when opening and closing windows RRS feed

  • Question

  • Visual Studio Community 2013 Update 4 (12.0.31101.00)

    I've been working on a large project for the past twelve months on and off and it's grown considerably in the past couple of months.

    We've started to noticed a problem when navigating from a search screen to a details screen...

    1. Open the search screen.

    2. Click a record link and open the details screen.

    3. Make amendments and save the record. Close the screen.

    4. Staying on the search screen, open another record as above, edit, save and close the screen bringing you back to the search screen.

    5. The third time we click a record to open it, the header for the window that opens show's the detail of the previous record. For example the window tab would show "Next Customer - Customer Detail" when infact it shows "Previous Customer -...". However, the details in the form controls of the window are for the next customer, NOT the previous customer despite their name being in the heard. (I've set the summary property to the Company Name)

    From here you can save the record and the details save fine. The problem starts when you try to close the window as it will not close. You have to close the search window first, this now populates the correct customer name in the customer details screen header tab and allows us to close it without trouble.

    If you try too many times to close the customer details screen without closing the search screen first the silverlight client hangs and has to closed forcefully.

    The problem can be replicated in VS debug and published production apps.

    Anyone else experience this? Any pointers really would be appreciated.

    Tuesday, July 7, 2015 2:03 PM

Answers

  • Hi Paul,

    Sounds like the problem with the overflow control used by the tabs.

    If you can try the standard shell instead of the cosmopolitan shell it should improve.

    The shell needs fixing.

    Dave

    ps. unless it is a different problem :)


    Dave Baker | AIDE for LightSwitch | Xpert360 blog | twitter : @xpert360 | Xpert360 website | Opinions are my own. For better forums, remember to mark posts as helpful/answer.

    Tuesday, July 7, 2015 2:23 PM

All replies

  • Hi Paul,

    Sounds like the problem with the overflow control used by the tabs.

    If you can try the standard shell instead of the cosmopolitan shell it should improve.

    The shell needs fixing.

    Dave

    ps. unless it is a different problem :)


    Dave Baker | AIDE for LightSwitch | Xpert360 blog | twitter : @xpert360 | Xpert360 website | Opinions are my own. For better forums, remember to mark posts as helpful/answer.

    Tuesday, July 7, 2015 2:23 PM
  • That does it Dave, thank you!

    I'd forgotten the Cosmpolitan shell had trouble. It's a shame really as the Standard shell looks so old fashioned in my opinion. I might take a look at some of your themes and see if we can make it look a bit prettier.

    The biggest loss is the logo though. Oh well, stability over eye candy really has to take priority in this case.

    Thanks for your help again Dave.

    Paul.

    Tuesday, July 7, 2015 2:38 PM