locked
IOS Release build in Visual Studio shows error "Debug is not enabled in the current configuration." RRS feed

  • Question

  • User75954 posted

    Hi all,

    Since a few days (I think since last updates of Xamarin.Forms), I am getting an error message when I try to do a Release build of my IOS app. The message says: "Debug is not enabled in the current configuration. Please Start Without Debugging or change it in Properties -> iOS Build."

    A screenshot of the error message:

    So I took a look at the properties, but I did not understand what I had to change. As far as I know I did not change anything in the properties.

    Also a screenshot of the properties of the project:

    Setup information:

    • MacBook with Parallels, running Windows 8.1
    • Visual Studio 2013
    • Project was previous created in Xamarin.Forms 1.2.3 and updated to 1.3.1 last week.

    Does anyone know how to resolve this problem?

    Monday, January 26, 2015 9:14 AM

All replies

  • User75954 posted

    I found this bug report on BugZilla, which seems to be about the same problem. I have Xamarin 3.9.236.0 installed with Xamarin.IOS 8.6.0.0, so it should be fixed in this version, right?

    Monday, January 26, 2015 9:54 AM
  • User75954 posted

    Checking the "Enable debugging" checkbox and build in Release mode enables me to make a Release build, but of course this way the appsize is significantly larger.. When I uncheck this checkbox again I get the same error message.

    Monday, January 26, 2015 10:07 AM
  • User904 posted

    @Guido_Kersten? It is not recommended to enable debugging on release build. Release build will not contain any debugger symbols to keep smaller binary size, which is ideal for publishing.

    but of course this way the appsize is significantly larger

    You may need to change the Linker behaviour to Link SDK Assemblies Only to reduce the appsize.

    Monday, January 26, 2015 12:37 PM
  • User75954 posted

    I know @Prashant? it was just to check if it works and it did, but it's not what I want to do.. I just want to build a normal Release build..

    I also tested a creating a news Forms project and try to build for Release.. Same error message is shown.. So it's not project bound

    Monday, January 26, 2015 4:47 PM
  • User75954 posted

    I found out that when I build my app using the DEBUG -> Start without debugging, from the context menu with Release configuration selected the app builds.. but after the splashscreen the app immediately crashes without any errors being logged.. I normally use the 'play button' but that's still giving me the error message.

    Monday, January 26, 2015 5:23 PM
  • User57571 posted

    I am having the same problem.

    Monday, January 26, 2015 6:35 PM
  • User75954 posted

    Ok, so I installed the hotfix after @Prashant? sent me an email, more info about the hotfix on BugZilla. When I build my app via DEBUG -> Start without debugging, from the context menu with Release configuration selected it builds successfully and I can finally publish my app again. But I am still getting the error message when I try to build the app by normally clicking the "play" button. Hopefully this gets fixed with the next stable release. For now I can at least move on with my work.

    Tuesday, January 27, 2015 1:25 PM
  • User77850 posted

    Same as @Guido_Kersten?. When I have to debug on my iPhone, I have to choose “Ad-Hoc" | "iPhone" in the Release Configuration Menu, and thereafter, in the Visual Studio menu, clicking "Debug" --> "Start Without Debugging".

    Following these exact steps, I was finally able to deploy to my iPhone.

    When simply clicking "Play" next to the "Release Configuration Menu", a message occurred stating that I should turn off debugging in my properties.

    Tuesday, January 27, 2015 2:29 PM
  • User62417 posted

    same problem...

    Wednesday, January 28, 2015 12:46 AM
  • User5846 posted

    I have the same issue. Cannot deploy to an iPhone

    Monday, January 18, 2016 2:16 PM
  • User241022 posted

    +1

    Sunday, October 30, 2016 9:16 PM
  • User1278 posted

    Same issue here. But to add, I have another configuration that works fine. I created a new configuration to get around another issue (spaces in path breaks remote simulator). So:

    1. Configuration "Debug iOS" tries to launch but gets "Failed to Install" error.
    2. Copied configration to "DebugiOS", now I get "Debug is not enabled" error.

    Ideas?

    Wednesday, March 8, 2017 4:56 PM
  • User354874 posted

    This is still happening, at least for me. Got to use: Debug -> Start Without Debugger.

    Monday, December 4, 2017 10:22 AM
  • User362290 posted

    I have the same issue too :(

    Thursday, December 7, 2017 6:35 AM
  • User362606 posted

    so how to resolve this problem?

    Friday, December 8, 2017 9:30 PM
  • User267719 posted

    @KimNiebling said: Same as @Guido_Kersten?. When I have to debug on my iPhone, I have to choose “Ad-Hoc" | "iPhone" in the Release Configuration Menu, and thereafter, in the Visual Studio menu, clicking "Debug" --> "Start Without Debugging".

    Following these exact steps, I was finally able to deploy to my iPhone.

    When simply clicking "Play" next to the "Release Configuration Menu", a message occurred stating that I should turn off debugging in my properties.

    thanks, that's working

    Monday, January 8, 2018 4:21 PM
  • User364462 posted

    @DonCB2B said:

    @KimNiebling said: Same as @Guido_Kersten?. When I have to debug on my iPhone, I have to choose “Ad-Hoc" | "iPhone" in the Release Configuration Menu, and thereafter, in the Visual Studio menu, clicking "Debug" --> "Start Without Debugging".

    Following these exact steps, I was finally able to deploy to my iPhone.

    When simply clicking "Play" next to the "Release Configuration Menu", a message occurred stating that I should turn off debugging in my properties.

    thanks, that's working

    @DonCB2B said:

    @KimNiebling said: Same as @Guido_Kersten?. When I have to debug on my iPhone, I have to choose “Ad-Hoc" | "iPhone" in the Release Configuration Menu, and thereafter, in the Visual Studio menu, clicking "Debug" --> "Start Without Debugging".

    Following these exact steps, I was finally able to deploy to my iPhone.

    When simply clicking "Play" next to the "Release Configuration Menu", a message occurred stating that I should turn off debugging in my properties.

    thanks, that's working

    yeah , its working

    Wednesday, January 10, 2018 8:42 AM
  • User364628 posted

    thanks :smile:

    Tuesday, January 16, 2018 9:41 AM
  • User297679 posted

    @GuidoKersten said: Hi all,

    Since a few days (I think since last updates of Xamarin.Forms), I am getting an error message when I try to do a Release build of my IOS app. The message says: "Debug is not enabled in the current configuration. Please Start Without Debugging or change it in Properties -> iOS Build."

    A screenshot of the error message:

    So I took a look at the properties, but I did not understand what I had to change. As far as I know I did not change anything in the properties.

    Also a screenshot of the properties of the project:

    Setup information:

    • MacBook with Parallels, running Windows 8.1
    • Visual Studio 2013
    • Project was previous created in Xamarin.Forms 1.2.3 and updated to 1.3.1 last week.

    Does anyone know how to resolve this problem?

    In Visual Studio 2017, it will be available in iOS Debug tab.

    Monday, April 16, 2018 9:46 AM
  • User237535 posted

    January 2019 here. Still fucked

    Friday, January 11, 2019 4:29 PM
  • User382781 posted

    Ran in to this after doing an Ad-Hoc Build. Seems like the Provisioning was stuck on the Ad-Hoc build no matter how I tried to change the Build configuration back to Debug. The debug build would sign with the Ad-Hoc information.

    What worked for me to fix it;

    Set build config and provisioning profile as desired for Debug in Visual Studio. Long press uninstall the app on the phone. Close Visual Studio Disconnect Phone Reboot the XCode Mac Reboot phone Start Mac Start/Connect phone Re-open Visual Studio

    Hopefully this helps someone, I spent way too much time on it.

    Friday, February 22, 2019 5:18 PM
  • User365524 posted

    Close and re-open VS it worked for me. :smile:

    Tuesday, March 5, 2019 3:16 AM