none
Error Loading Azure Subscription - Visual Studio 2015

    Question

  • When Attempting to connect to my subscriptions in Visual Studio 2015 I get the following error  

    One or More Errors Occurred while loading subscriptions

    an error occurred during the sign in process: value can not be null 

    Parameter Name: accountKey

    I have tried from 2 different computers and have confirmed that I have 2 subscriptions for this account

    Any suggestions? 

    Tuesday, March 14, 2017 5:38 AM

All replies

  • Hi Chris Riggenbach,

    Welcome to MSDN forum.

    The issue may be related to Azure Key, please make sure you could log in Azure Portal: https://portal.azure.com. If everything is ok, you could follow the steps in screenshot to connect to your Azure Subscriptions:

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Chris Riggenbach Wednesday, March 15, 2017 3:37 PM
    • Unmarked as answer by Chris Riggenbach Friday, March 17, 2017 1:39 AM
    • Proposed as answer by Apelem Wednesday, March 29, 2017 8:37 PM
    Wednesday, March 15, 2017 7:59 AM
  • This did not resolve the issue as when I go to publish a web app to azure it still is unable to see my subscription - Please provide additional guidance 
    Friday, March 17, 2017 1:52 AM
  • Hi Chris Riggenbach,

    Thank you for your update.

    Could you see your Azure Subscription in Sever Explorer?

    If you could see it, you have connected to your subscription. when you go to publish the web app, you could change another way, please the blog:

    https://blogs.msdn.microsoft.com/avkashchauhan/2012/06/26/deploying-windows-azure-website-using-visual-studio-web-publish-wizard/

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 17, 2017 9:51 AM
  • Hi,

    We are also seeing this issue which is blocking one of our developers from being able to deploy an Azure Resource Manager (ARM) template.

    From what I can tell it is due to the user not being permissioned for all the subscriptions in a tenancy or having disabled subscriptions. The developer having the issue is owner for 2 out of 4 subscriptions on a tenancy and therefore errors when attempting to access the subscriptions in VS2015.

    I on the other hand have access to all 4 subscriptions within the tenancy and therefore don't have any issue access the subscription. I'm going to attempt to give the developer access to all subscriptions (even if it is just reader) and see if then gets around the issue.

    Thanks

    Friday, April 28, 2017 8:09 AM
  • Hi Dan Richardson,

    Welcome to MSDN forum.

    Please open a new thread to describe your issue, thank you for understanding.

    Best regards,

    Joyce 


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, April 28, 2017 8:17 AM
  • Try to sign in on the top right corner menu instead of Server Explorer extension.

    Just click on Account Settings… > Remove your account, add it again then check if your subscription is showing up on the Server Explorer extension.


    • Edited by wagsousa Tuesday, July 25, 2017 6:38 PM
    Tuesday, July 25, 2017 6:37 PM
  • Any news on this.

    I get the same error message when I try to connect to a subscription using the tenant admin account. I have tried signing in in the top right corner.
    Friday, August 18, 2017 9:03 AM