none
Surface to design reports does not appear using the ReportViewer Tasks Smart Tags Panel RRS feed

  • Question

  • I follow a simple Beth Masii video tutorial, make a new proyect, I have Form1 and a Dataset with Customer NorthWind Table. Then, from the Toolbox Window  I Drag & Drop a Microsoft ReportViewer Control to my Form1, and click for ReportViewer Tasks Smart Tags Panel. Because this is the first Report that I am going to do I don't have already any report, I click "Design a new Report". According to the Video then open up the Report Designer, but for me, there is no open any Report Designer window, simply, no error, no message, nothing, it seems that I did not click "Design a new Report" link.

    Please help me, I have read a lot of documentation and I can´t find why this happens.

    I have Visual Studio 2008, Sql Server 2008 R2 Express Edition, I have already Report Manager, my Report Server Database, I have Windows Vista Home Basic SP2, SQL Server Reporting Services executing, my URL testing for Report Manager is Ok, I look at ReportServerService log files and can´t see any error message that suggest any problem.

    Thank you

    Rogelio Reyna

     


    Rogelio Reyna
    Saturday, October 2, 2010 9:08 PM

Answers

  • Hey Rogelio, there is another way to launch the Report Wizard if you right click on your project (or from File Menu) and then select 'Add New Item' you will see in the dialog that there is a Reporting category on the left. Select it then you should have two template items to select from 'Report' and 'Report Wizard', select the Wizard option and you should get the Report Wizard. Also if you are creating a new project there should also be a Report Project type for WinForms and a Report Website option for websites; starting a project with either one of these will launch the wizard as well. Let me know if you have any more questions.

    Matt M 
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties

    • Marked as answer by RogeReyna Saturday, October 9, 2010 4:32 AM
    • Unmarked as answer by RogeReyna Saturday, October 9, 2010 4:32 AM
    • Marked as answer by RogeReyna Saturday, October 9, 2010 4:32 AM
    Tuesday, October 5, 2010 8:08 PM

All replies

  • Ok, additional information:

    First I Installed VB Express Edition 2008, but I had not Print and Design Report avalilable, so after, I installed the Visual Studio 2008 60 Days Trial, and now I have the MicrosoftReportViewer but my Report Design Surface do not appears. Last, I uninstalled VB Express Edition 2008 and Installed the Microsoft Report Viewer 2010, but still I don'nt have that feature available.

    I appreciate your help, please.

     


    Rogelio Reyna
    Monday, October 4, 2010 4:45 AM
  • The Report Designer for the Microsoft ReportViewer control is only available in Visual Studio Standard editions or higher; however you can install the ReportViewer redist which will install the runtime control but none of the report authoring components, which is what you are seeing. If you want to use the 2008 version of the control and installing VS standard or higher is not an option then you could install Visual Studio Web Developer Express 2008 and then install the ReportViewer Add on for Web Developer Express 2008 from here:

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=b67b9445-c206-4ff7-8716-a8129370fa1d&displaylang=en

    You will have to do some manual work to copy reports and datasets between projects but it should work. Also there currently is no add on for the 2010 express editions for the control.

    Matt M 
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties

    Monday, October 4, 2010 5:50 PM
  • Thank you Math, but still I have a doubt, because now I don't have Visual Basic Express Edition installed, but The complete Visual Studio 2008 Professional (Although the 60 days trail, but still the "complete edition") it's supposed that the ReportViewer Tasks Smart Tags Panel should start the Report Wizard, but it's not.

    I took another report example (.rdlc) and erase all the fields, I added it to my proyect, and click on it, and finally I could see the Design Surface and could add fields to the report. What I  still don't have available (or I don't know how to do it) is start the Report Wizard.

    Is there any way to start the Report Wizard without the ReportViewer Tasks Smart Tags Panel?

    I appreciate your comments.

    Rogelio Reyna

     

     


    Rogelio Reyna
    Tuesday, October 5, 2010 3:30 AM
  • Hey Rogelio, there is another way to launch the Report Wizard if you right click on your project (or from File Menu) and then select 'Add New Item' you will see in the dialog that there is a Reporting category on the left. Select it then you should have two template items to select from 'Report' and 'Report Wizard', select the Wizard option and you should get the Report Wizard. Also if you are creating a new project there should also be a Report Project type for WinForms and a Report Website option for websites; starting a project with either one of these will launch the wizard as well. Let me know if you have any more questions.

    Matt M 
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties

    • Marked as answer by RogeReyna Saturday, October 9, 2010 4:32 AM
    • Unmarked as answer by RogeReyna Saturday, October 9, 2010 4:32 AM
    • Marked as answer by RogeReyna Saturday, October 9, 2010 4:32 AM
    Tuesday, October 5, 2010 8:08 PM
  • Hi Matt:

    I appreciate your help, maybe something is wrong in my Visual Studio 2008 Professional version because I select "Add New Item", and I see the Reporting Category, but In this, just appears one option: Crystal Report, nothing else, Could you advise me what could be wrong,? Why does not shows The Report Wizard option?

    Thank you

    Rogelio Reyna

     

     


    Rogelio Reyna
    Wednesday, October 6, 2010 2:51 AM