locked
Windows 2008 R2 SP1 Breaks default document redirection RRS feed

  • Question

  • User1306805175 posted

    Just installed SP1 on a production Windows 2008 R2 Std. The default document redirection does not work at all on CLASSIC ASP sites. The same server hosts 3 different sites of which 2 are classic ASP and a development one which is ASP.NET 4. The ASP.NET default document works but the classic doesn't.

    Only solution was to redirect 404 Error Page to my index.asp.

    Tried to copy the index.asp to index.html, default.asp etc etc with no luck.

     Also the IIS Manager clearly stated that the "Default Document" feature was enabled and inherited from the default settings.

    Even tried to overwrite it (deleted the original default documents and re-entered them specifically for the site) with no luck.

    Looks like this is broken and waits for a patch !

    PS. Might be important that there is no "Default Web Site" on my configuration. Just 3 custom ones.

    Thursday, February 24, 2011 6:20 AM

Answers

  • User1306805175 posted

    Reproduced the problem as follows:

    Download and Install Windows 7 Enterprise Trial x64

    Turn on Windows Features: IIS

    Download and Install .NET Framework x64 (dotNetFx40_Full_x86_x64.exe)

    Turn on Windows Features: IIS-> Web  CGI, ISAPI, ASP, ASP.NET etc

    Using the default web site (default document is : iisstart.htm) everything works fine in both Classic and Integrated mode even though on ISAPI & CGI Restrictions both x86 and x64 .NET 4.0 aspnet_isapi.dll are set to "not allowed"

     ---> Install Windows 7 SP1 x64......

    Default document redirection now works only in Integrated mode !

    I don't know if this forum is monitored by IIS personnel or at least an MVP in IIS but still hope it will help someone to avoid problems after installing Windows 7/2008 SP1 and to get an answer about this breaking change !

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Sunday, February 27, 2011 6:02 PM

All replies

  • User1306805175 posted

    Found the reason this was happening. This is a breaking change that SP1 made to the filters on my IIS. Can't verify it but after SP1 on my IIS "ISAPI and CGI Restrictions" that had ASP.NET v.4.0.30319 (32/64 bit) as "Not Allowed" caused the aspnet_isapi.dll to cause faults to my default document redirection since the it was executed before that (ExtensionlessUrl-ISAPI-4.0_32bit) even though my module order was different !

     Logic suggests that having the DefaultDocumentModule (defdoc.dll) before the IsapiFilterModule (filter.dll), that would be enough to redirect pages. But since the application pool the site actually was ASPNET 4.0 it "had" to load the IsapiFilter that was disabled !

     Obviously either the behavior is different than pre-SP1 OR SP1 did change the metabase of my IIS. That will require further investigation and hope someone else can verify this too !

    Sunday, February 27, 2011 7:29 AM
  • User1306805175 posted

    Reproduced the problem as follows:

    Download and Install Windows 7 Enterprise Trial x64

    Turn on Windows Features: IIS

    Download and Install .NET Framework x64 (dotNetFx40_Full_x86_x64.exe)

    Turn on Windows Features: IIS-> Web  CGI, ISAPI, ASP, ASP.NET etc

    Using the default web site (default document is : iisstart.htm) everything works fine in both Classic and Integrated mode even though on ISAPI & CGI Restrictions both x86 and x64 .NET 4.0 aspnet_isapi.dll are set to "not allowed"

     ---> Install Windows 7 SP1 x64......

    Default document redirection now works only in Integrated mode !

    I don't know if this forum is monitored by IIS personnel or at least an MVP in IIS but still hope it will help someone to avoid problems after installing Windows 7/2008 SP1 and to get an answer about this breaking change !

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Sunday, February 27, 2011 6:02 PM
  • User85936540 posted

    You may solve this problem by running following command.

    aspnet_regiis -i

     

    http://msdn.microsoft.com/en-us/library/k6h9cz8h.aspx

     

    Wednesday, March 9, 2011 7:56 PM
  • User-2144789271 posted

    You may solve this problem by running following command.

    aspnet_regiis -i

     

    OK, Tried running that command and was told it was unrecognized  blah blah blah....

     

    Where exactly do you run it from
    ?

    Thursday, August 11, 2011 8:17 PM
  • User-2144789271 posted

    Where does one turn on intergrated mode? Do I want intergrated mode ?

     

    Please excuse my ignorance.

    Thursday, August 11, 2011 8:19 PM
  • User-2144789271 posted

    Problem Resolved!                           Uninstalled SP1.

     

    Please FIX THIS and release Patch.

    Thursday, November 10, 2011 6:03 PM