none
Failed installation RRS feed

  • Question

  • So, I tried to install the 4.0 version, and I got this:

    OS Version = 6.1.7600, Platform 2
    OS Description = Windows 7 - x64 Home Premium Edition 
    CommandLine = C:\0cd8efdce69280afa40d0ebb30\\Setup.exe /x86 /x64 /ia64 /web
    TimeZone = GMT Daylight Time
    Initial LCID = 2057
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: Disabled
    Number of applicable items: 11

    evaluating IsPresent:
    Exe (C:\0cd8efdce69280afa40d0ebb30\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (C:\Users\Karen\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\Windows6.1-KB958488-v6001-x64.msu) failed with 0x8000ffff - Catastrophic failure .
    Final Result: Installation failed with error code: (0x8000FFFF), "Catastrophic failure " (Elapsed time: 0 00:00:42).

    If anyone could help with this, I'd appreciate it

    Friday, July 13, 2012 3:55 PM

Answers

All replies

  • Follow this sequence:

    Follow these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Friday, July 13, 2012 8:56 PM
  • Well, that didn't work, just did the same as before, here's the logs though

    https://skydrive.live.com/redir?resid=E8209151AD12D92D!129&authkey=!ACAEqw15pIbSmJQ



    • Edited by Vexillius Friday, July 13, 2012 9:45 PM
    Friday, July 13, 2012 9:44 PM
  • For some reason, the .NET Framework 4.0 install log is not present in your vslogs.cab.

    Any chance you cleared your %temp% directory after the last failed attempt and before you ran Collect.exe?

    Please retry the install, then run Collect.exe immediately after it fails.

    The other possibility is that the install fails so early that no log is created.

    I also found this thread that pertains to "Installation failed with error code: (0x8000FFFF), "Catastrophic failure " "

    http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/3a18bac6-f477-4a00-aac8-710577c09878

    You can try Andrew's suggestions if you have not already done so.

    Friday, July 13, 2012 10:11 PM
  • Ah right, I may have whilst deleted it whilst retrying those steps...I looked at the windows updater like it said in the other thread and found that 79 updates had failed to install also...I thought it may be linked to this problem, so I took the opportunity to collect that information, and hopefully it will give some further indication of the problem? I'll keep trying the steps though https://skydrive.live.com/redir?resid=E8209151AD12D92D!129&authkey=!ACAEqw15pIbSmJQ

    Thanks for the continued help as well, I do appreciate it.

    Friday, July 13, 2012 10:36 PM
  • Unfortunately, the log has little to add to "Windows6.1-KB958488-v6001-x64.msu) failed with 0x8000ffff - Catastrophic failure ."

    In the thread related to this error that I linked for you previously, the OP solved the problem by reinstalling his OS.

    Given your situation with the failed updates, I suggest you consider the same course.

    Friday, July 13, 2012 11:52 PM
  • Ah right, ok, well thanks for the help, is there any way you could link me to somewhere where it would show me how to re install my OS? I'm not exactly a computer pro so I wouldn't have a clue where to start, and would there be a chance I'd lose any saved documents etc on my computer if I did that?
    Sunday, July 15, 2012 11:35 AM
  • The forums for Windows 7 user support are here:

    http://answers.microsoft.com/en-us/windows/forum/windows_7

    This article may also be helpful:

    http://www.sevenforums.com/tutorials/3413-repair-install.html

    Sunday, July 15, 2012 12:54 PM