none
failure executing the receive pipeline - Finding the document specification by message type "http://schemas.microsoft.com/Edi#WildcardSchema" failed RRS feed

  • Question

  • Hi, I followed the walktrough at MSDN url

    http://msdn.microsoft.com/en-us/library/ff629677.aspx

    Receiving EDI Interchanges and Sending Back an Acknowledgement. I followed instructions, copied the text and created a test.edi file, when running the sample it gets suspended and I get the following error in BTS

    There was a failure executing the receive pipeline: "Microsoft.BizTalk.Edi.DefaultPipelines.EdiReceive, Microsoft.BizTalk.Edi.EdiPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Source: "EDI disassembler" Receive Port: "rpD98AInterchange" URI: "E:\tutorial\MSDN-EDIwalkThrough\IN\*.edi" Reason: Finding the document specification by message type "http://schemas.microsoft.com/Edi#WildcardSchema" failed. Verify the schema deployed properly. 

    I have already deployed the schema in an application and referenced the "Biztalk EDI Application. I did some research but could not find a response. One thing I noticed that in the message context in the service details dialog box I do not have a row for MessageType......

    Thanks in advance

    Monday, August 18, 2014 3:00 PM

All replies

  • Did you create a row with the proper namespace on the Local Host Settings section of the Agreement?
    Monday, August 18, 2014 3:27 PM
  • I think you mean the "Local Host Settings " under Transaction Set Settings section? it is  indicated in the walkthrough

    i- If you are using one of the standard schemas shipped with BizTalk Server, on the Local Host Settings page under the Transaction Set Settings section, select the namespace for the schema to be used to process the incoming interchange

    So I have a row , Default is cheked, followed by several empty fields (UNH2.1, 2.2, 2.3,2.5, UNG 2.1, 2.2) then afield titled "TargetNamespace where I have 2 options

        schema.microsoft.com/Edi/Edifact

    and

        schema.microsoft.com/Edi/EdifactServiceSchema

    Is there any other config that should be done or is it OK?

    Monday, August 18, 2014 4:19 PM
  • Also, I forgot to mention that in item j On the Envelopes page under the Transaction Set Settings , no value is indicated for UNG3.1 all other tags (I have put ZZZ

    UNG3.1                          

    Enter a value for application receiver identification.

    UNG3.2                          

    Enter a value for application receiver code qualifier, such as ZZZ.

    Monday, August 18, 2014 4:26 PM
  • If you did not change the namespace on the EDIFACT schema, then the Default row is fine.

    I would also recommend disabling the Fallback Settings to eliminate that as a possible cause.

    Monday, August 18, 2014 4:42 PM
  • I did but it did not help, any other idea?
    Tuesday, August 19, 2014 2:12 PM
  • Johns, any other idea how to check what is going wrong?
    Wednesday, August 20, 2014 10:05 AM
  • I managed to make it work as it seems that there was an issue because my platform was 64bit .Now, the interchnage is generated but there are 2 issues

    - Acknowledgement is not generated

    - the interchange is not taling into consideration the agreement associated with the send ports, it is using the fallback settings as I can see in the output file as follows

    UNB+UNOB:1+BTS-SENDER:ZZZ+RECEIVE-PARTNER:ZZZ+140821:1134+2++++0++0'UNH+2+APERAK:D:............

    Thursday, August 21, 2014 10:19 AM
  • You need to associate the Send Port with the Agreement!

    Open your Agreement:

    In the Tab (You->Them):

    Interchange Settings | Send Ports

    Choose your Send Port, click OK

    Restart your host instance, and now the agreement should be used instead of the fallback settings.

    Morten la Cour

    Thursday, August 21, 2014 10:34 AM
  • Correct, in fact, when I have redone the excercise I forgot to do this step. Now I am getting the interchange in the right folder but acknowledgement is not getting generated
    Thursday, August 21, 2014 11:10 AM