none
Azure AD SSO for ADP Workforce Now not filling credentials

    Question

  • We have just recently had our service with ADP upgraded and are now using the Workforce Now service which is supported by Azure AD for SSO.  I added ADP Workforce Now from the Application Gallery and configured it for "Password Single Sign-On".  (The only other option was "Existing Single Sign-On", and we don't have a pre-existing SSO for ADP.)

    I assigned the app to a few accounts, and tested the SSO.  Using IE 11 on Windows 10, I logged into portal.office.com, and selected the ADP Workforce Now icon from the app launcher menu.  The first time, I had to download and install an extension, and restart the browser a couple of times.  Then I tried launching the ADP site from the app launcher menu again, and got a pop up from AzureAD asking for my credentials.  After entering them, there was a delay, and then the ADP workforce now login page loaded.  And that's it.  No credentials were filled in, no auto login, it was just sitting at the login page waiting for me to enter my credentials.   I tried logging in manually, thinking maybe I had to do it once manually before the SSO would kick in, but after logging out and launching it again from the O365 app launcher menu, I got the same results.  It is clearly going through a redirect, but when the redirect takes me to the ADP login page, it doesn't fill anything in.  

    Any idea what's wrong here?  I was really looking forward to offering SSO to our timeclock system, but as of now it doesn't work at all. 

    Monday, March 6, 2017 4:56 PM

All replies

  • Can you please send me a note at asteen@microsoft.com with details of this outage so I can put you in touch with the engineering team here?

    Thanks!

    Adam.


    Adam Steenwyk | Senior Program Manager | asteen@microsoft.com

    Tuesday, March 7, 2017 4:42 PM
  • Hey NeighborGeek, did this ever work out for you? I'm investigating whether our organization can also use Azure AD for ADP SSO.

    Wednesday, August 22, 2018 6:12 PM
  • It's been a while, and unfortunately my email thread about this only goes so far.  I think we may have switched to a phone conversation at that point.

    I believe it came down to an issue with the Access Panel Extension for IE.  It did work in Edge once the access panel extension was released for Edge.  Somewhere after that, I think I hit another snag in the process, and then found out that we would be changing vendors, so I dropped work on SSO with ADP altogether. 

    That said, I know AzureAD had several different options for SSO integration with ADP, depending on which of ADP's many products/services you use.  I would definitely give it a try, don't assume that your experience will mimic mine. 

    Wednesday, August 22, 2018 6:24 PM