locked
Report Viewer Toggle problem RRS feed

  • Question

  • User1443511503 posted

    I am embedding my RS reports into .aspx pages. If I have a toggle for a hidden row the toggle button
    causes a post back but the screen refreshes and the report is in it's original
    state without the data showing from my hitting the toggle. When i am designing it using the
    Report Builder all works fine....

    please help.

     

    Thanks

    Thursday, January 6, 2011 4:40 AM

Answers

  • User1443511503 posted

    Hi,

     

    I don't think is that - it is a postback problem - same thing happens when i want to go to the 2nd page - the reports reloads and sits on the 1st page all the time... 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, January 14, 2011 4:24 AM

All replies

  • User-830595639 posted

    Hi,

    I am not sure what you want to toogle in your Report using asp button. If you are trying to do drilldown then the asp button is not required.

    Please explain it in detail.

    Thanks

    Nishant


    Friday, January 7, 2011 1:45 AM
  • User1443511503 posted

    the toggle button is the '+' image - drilldown if you like 

    Friday, January 7, 2011 3:08 AM
  • User1471008070 posted

    Hi,

    I think you might give the incorrect steps for drill-down feature, I would recommend you refer to step 8.  Add a drill-down feature to the main report in my walkthrough at this link http://blogs.msdn.com/b/sqlforum/archive/2011/01/03/walkthrough-add-a-subreport-in-local-report-in-reportviewer.aspx 

    Thanks,
    Challen Fu

     

    Thursday, January 13, 2011 2:20 AM
  • User1443511503 posted

    Hi,

     

    I don't think is that - it is a postback problem - same thing happens when i want to go to the 2nd page - the reports reloads and sits on the 1st page all the time... 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, January 14, 2011 4:24 AM
  • User1471008070 posted

    Hi plaese add below code to your code-behind:

            protected void Page_Load(object sender, EventArgs e)
            {
    
                if (!IsPostBack)
                {
                }


     

    Tuesday, January 18, 2011 4:56 AM
  • User-1940639243 posted

    Hi,

    I'm facing the same issue,

    The previous posts doesn't solve the issue,

    The ReportViewer control is placed within an UpdatePanel (ASP.NET ajax control) which prevents postbacks.

    I think this issue is related to the toggle itself.

    Can you please help me solve this issue?

    Regards,

    Bader

    Tuesday, August 28, 2012 6:39 AM