none
How to disable "document open in another project" message?

    Question

  • Hi all.

    It is annoying and useless. I want to hide it forever. How can I do it?

    Thank you.


    Sunday, October 09, 2016 8:10 PM

Answers

All replies

  • Hi EugeneKozlov,

    Thanks for your post.

    For your question , does the error message shows when you are using Visual Studio?

    It would be better to express the detailed information about the document you tried to open and your VS version.

    If so, I suggest you can try some devenv switches in command prompt check if it can help you.

    a. Run devenv /Safemode to see if you can apply it correctly. This can eliminate the possibility that   third party Add-ins or packages are causing problems.

    b. Run devenv /Resetsettings to eliminate the cause of corrupted settings.

    c. Run devenv /ResetSkipPkgs in Command Prompt.

    d. Run devenv /resetsuerdata

    I suggest you can try to close the Anti-virus software or the firewall or other tools on your machine or you can try to restart your machine would be better.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Monday, October 10, 2016 8:12 AM
    Moderator
  • I am unsure that we are talking about the same things.

    This message is correct. This document is really opened in another project. It is not some VS error.

    I DO know that this document is opened in another project. I just want to get rid of this message.

    Monday, October 10, 2016 8:51 PM
  • @EugeneKozlov,

    >>Document open in another project" message.

    I met this message before, generally this message means that it was used or opened by other program/process running in the background. I don't find settings which could disable it in VS IDE, it was not the Visual Studio's issue.

    A workaround I could think of is that you could open your task manager, and close the background processes which use this file.

    If still no help, please share me the detailed steps or a sample, so I could really repro this issue in my side.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Tuesday, October 11, 2016 2:58 AM
    Moderator

  • A workaround I could think of is that you could open your task manager, and close the background processes which use this file.

    I have two instances of Visual Studio with the same file opened. I need these two instances and I can't close one of them.

    So, VS don't have any mechanism to disable this window... Okay, I understood.

    Thank you.

    Tuesday, October 11, 2016 6:07 PM