locked
Could not connect to the debugger RRS feed

  • Question

  • User308226 posted

    My Xamarin iOS app will build successfully, however, during launch it will flash a black screen and immediately return to my phones home screen exiting my app without an error. Upon reviewing Xamarin Studio, the status appears at top:

    Waiting for debugger to connect to Phone on port 10000 view USB...

    and simply hangs for ~90 seconds. Afterwards the message "Could not connect to the debugger" appears within Xamarin Studio

    How can this be alleviated?

    Wednesday, March 22, 2017 3:57 AM

Answers

  • User308226 posted

    I got this to work. I had not updated the info.plist with the proper code to permit Facebooks domains, rolled out for iOS 9 developers.facebook.com/docs/facebook-login/ios, this is closed

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, March 23, 2017 12:27 AM

All replies

  • User261475 posted

    Looks like the App crashes on launch before the debugger is connected. Does this problem also happend with new empty projects?

    Wednesday, March 22, 2017 11:17 AM
  • User308226 posted

    No it does not occur with new projects. I am attempting to add the Xamarin Facebook iOS package to my project. Here the sample works: https://github.com/MattHarrington/FacebookiOSSample, but attempting to follow and incorporate into my new project throws the errors noted above.

    Wednesday, March 22, 2017 12:47 PM
  • User308226 posted

    I got this to work. I had not updated the info.plist with the proper code to permit Facebooks domains, rolled out for iOS 9 developers.facebook.com/docs/facebook-login/ios, this is closed

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, March 23, 2017 12:27 AM