none
Cannot create project

    Question

  • i have tried a lot of solutions like uninstalling all extentions and /uninstall / force, /safemode, /resetsettings and installing it without my anvi virus on and changing the permission in my regedit.exe to full permission but it doesnt work i have made a video to show my problem it seems to be something do with the c++ templates and when i installed it. it installed the sdk 8.1 windows but i have windows 10 so i dont know if thats the problem it doesn't let me change it to windows 10 sdk. https://www.youtube.com/watch?v=CDycIMcpuFM    When i open vs it closes without an error but when i try to open a c++ template it wont create one and then i will get the error after
    Thursday, September 22, 2016 9:40 PM

Answers

All replies

  • Hi Rapiidzz123,

    Thank you for posting in MSDN forum.

    1. >> i have made a video to show my problem it seems to be something do with the c++ templates and when i installed it

    I saw the video, agree with you that the C++ template is missing or corrupted, also notice that some application could block the template loading.

    Please go to Control Panel to check if you have installed the C++ related components well, see:

    2. If you have tried the uninstall and re-install but not help, since you didn't mention in which way you install the VS at first, how about inserting a good VS ISO to repair your VS.

    Before doing so, please check all the Windows update and make sure they are all to the newest.

    Your OS is Win 10, you definitely could install the Win 10 SDK, here is the download link:
    https://developer.microsoft.com/en-us/windows/downloads/windows-10-sdk

    If the above doesn't work, then you may try to running devenv.exe /log<log path> in Command Prompt, the log files will be generated in the <log path>.

    Then you can check and analyze the log file to see if there are anything incorrect.

    Or upload the file to https://onedrive.live.com/   and share the
    link with us.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Friday, September 23, 2016 7:55 AM
    Moderator
  • made a log and this is the errors i get https://onedrive.live.com/?v=TextFileEditor&id=E6F67E8600DFF5D6%21115&cid=E6F67E8600DFF5D6&parId=root
    Sunday, September 25, 2016 11:46 PM
  • Hi Rapiidzz,

    I open the link you offered but find the item doesn't exist.

    How about uploading it to us again?

    Besides, have you tried the restore Default Project Templates of visual studio?

    You can try this to restore missing templates:

    Please open Windows Explorer, and navigate to  <Visual Studio Installation Path>\Common7\IDE

    1.Delete the ItemTemplatesCache, ProjectTemplatesCache folder;

    2.Open Visual Studio Command Prompt  under Start menu -> All Programs -> Microsoft Visual Studio 2015 -> Visual Studio Tools (run it with Administrator privilege: right-click the program -> Run as administrator);

    3.Run the devenv /InstallVSTemplates switch;

    4.Run the devenv /Setup switch

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, September 26, 2016 8:15 AM
    Moderator
  • try this one. this worked for my friend https://1drv.ms/t/s!Atb13wCGfvbmdPx0sM7KJamEdRg
    Monday, September 26, 2016 2:22 PM
  • Hi Rapiidzz,

    Glad to hear you it worked. And thanks for sharing us your solution and result here.

    If you think your reply is helpful, please mark your reply as the answer, it will benefit to other community members who have the same issue. It will be easier for them to search the solution.

    Have a nice day:)

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Tuesday, September 27, 2016 2:19 AM
    Moderator
  • no sorry i mean i am still have the problem i meant the link should work now as you said it didn't work

    https://1drv.ms/t/s!Atb13wCGfvbmdPx0sM7KJamEdRg <--- onedrive this is my log with the warnings and errors in it


    • Edited by Rapiidzz Tuesday, September 27, 2016 6:41 AM
    Tuesday, September 27, 2016 6:40 AM
  • anyone know how to fix this from happening? https://1drv.ms/t/s!Atb13wCGfvbmdPx0sM7KJamEdRg
    Tuesday, September 27, 2016 2:18 PM
  • I might have the same problem but if I do then the symptoms are a bit different.

    I also cannot create a C++ Console project. When I try to, when I click "OK" the "Add Project" window flashes then is shown again. If I have a file open in VS then it is closed but nothing else happens. I could create a C++ Console projects previously.

    I did install the Python Tools Package on September 25 and there were errors. It created an activity log. Did that happen to you too? The first error record says:

    Extension will not be loaded because an extension with the same ID 'Microsoft.Windows.DevelopmentKit.Desktop' is already loaded at
    C:\PROGRAM FILES (X86)\COMMON FILES\MICROSOFT\EXTENSIONMANAGER\EXTENSIONS\MICROSOFT\WINDOWS KITS\8.1\DESKTOP SDK\...

    Perhaps I need to create a separate thread for my problem. I have not researched the preceding error so I will do that now.



    Sam Hobbs
    SimpleSamples.Info

    Tuesday, September 27, 2016 5:18 PM
  • i think ours might be a bit different since when i create a c++ project it just says failed to create but all the extensions seem to load ok. the only error i am getting in my log is 

    <record>361</record>
        <time>2016/09/26 14:19:37.759</time>
        <type>Error</type>
        <source>Microsoft.VisualStudio.CommonIDE.ExtensibilityHosting.VsShellComponentModelHost</source>
        <description>Still unable to load MEF component DLL: Could not load file or assembly &apos;Microsoft.VisualStudio.CodeSense, Version=14.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a&apos; or one of its dependencies. The system cannot find the file specified.</description>
        <path>C:\PROGRAM FILES (X86)\MICROSOFT VISUAL STUDIO 14.0\COMMON7\IDE\EXTENSIONS\YV23QZFA.FFC\Microsoft.VisualStudio.ApplicationInsights.dll</path>"

    but the rest are only warnings.

    oh and i have an activity log but i made my own log with devenv /log<log path>  

    ---------------------------------------------------

    just fixed my problem i made a log and then i checked for all the errors and there was one that is above and all i did to fix it was i loaded visual studio 2015 went to Tools>Extensions and updates> and then i found one called xamarin and i just clicked uninstall and then i was able to create a c++ console application without a problem hope this helps other people out!

    ----------------------------------------------------




    • Proposed as answer by Rapiidzz Tuesday, September 27, 2016 7:14 PM
    • Edited by Rapiidzz Tuesday, September 27, 2016 7:17 PM
    Tuesday, September 27, 2016 7:00 PM
  • Thank you.

    I tried to uninstall the extension that seems to be the problem using a specialized tool but it did not work so I won't mention what it is. I did a repair of VS and that has made things worse. So I will do an uninstall and reinstall. If I need help then I will post elsewhere.



    Sam Hobbs
    SimpleSamples.Info

    Tuesday, September 27, 2016 8:27 PM
  • Hi,

    Before uninstall the VS, you also need to make sure that VS install packages on your machine are complete and not broken. if the repair get things worse, I suggest you use a good ISO to repair it again first.

    Then you may share us your result here after the re-install VS.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Wednesday, September 28, 2016 5:21 AM
    Moderator
  • I uninstalled most of the extensions and then uninstalled and re-installed VS. Fortunately VS is now working, at least I can create a C++ console project.


    Sam Hobbs
    SimpleSamples.Info


    Wednesday, September 28, 2016 5:32 AM
  • Glad to hear you have had your issue resolved.

    And thanks for sharing us your solution and result here.

    You could your reply as the answer, it will benefit to other community members who have the same issue. It will be easier for them to search the solution.

    Have a nice day:)

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Wednesday, September 28, 2016 5:39 AM
    Moderator