none
Error Message After Fresh Install of SQL 2008R2 RRS feed

  • Question

  • Error HRESULT E_FAIL has been returned from a call to a COM component. (mscorlib)

    Program Location:

       at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
       at Microsoft.VisualStudio.ErrorHandler.ThrowOnFailure(Int32 hr, Int32[] expectedHRFailure)
       at Microsoft.VisualStudio.Shell.VsShellUtilities.GetWindowObject(IVsWindowFrame windowFrame)
       at Microsoft.SqlServer.Management.SqlStudio.Explorer.ObjectExplorerService.get_Tree()
       at Microsoft.SqlServer.Management.SqlStudio.Explorer.ObjectExplorerService.ConnectToServer(UIConnectionInfo connectionInfo, IDbConnection liveConnection, Boolean validateConnection)

    Friday, April 1, 2016 8:06 PM

All replies

  • Hi there, let us know in what part of the setup did you get that message
    Friday, April 1, 2016 8:08 PM
  • Install had finished. Its when attempting to connect to the server
    Friday, April 1, 2016 8:11 PM
  • So when you try to log in from SSMS login box?If yes, retry to log in using Windows instead of Sql Server principal

    Friday, April 1, 2016 8:16 PM
  • Yes, I am using Windows Currently but i will try SQL Authentication.

    Friday, April 1, 2016 8:27 PM
  • SQL Authentication works!!! Any idea why Windows wouldnt?
    Friday, April 1, 2016 8:28 PM
  • Did you choose on the installation process (one of the first steps, named Server Authentication) Sql Server and Windows Authentication Mode?

    Friday, April 1, 2016 8:35 PM
  • Hello,

    Have you configured Windows Firewall or any other security software to allow SQL Server access? Could you try disable any security software.

     

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    Friday, April 1, 2016 8:35 PM
    Moderator
  • Alberto,

    But by default Windows Firewall would not be interfere with one local connection, same physical machine, same default instance.

    Friday, April 1, 2016 8:38 PM
  • yea i enabled mixed mode during install and set an sa password.

    Ive installed SQL probably a hundred times before and never seen something like this.

    Friday, April 1, 2016 8:40 PM
  • Just in case, turn off WF at domain, private and public domain. 

    Just for dismiss...

    Friday, April 1, 2016 8:43 PM
  • You did apply the latest service pack after installation, didn't you?

    Friday, April 1, 2016 9:04 PM