none
Lost RDP connection after successfully deployment

    Question

  • Before I deployed the system, I can access to the host via RDP from a springboard server. My network admin has configured a VLAN seg on the router side so that I haven't set any VLAN id on the host side.

    But when the deployment finished, I cannot access to the host via RDP anymore. I am now using a 3rd party console to access to the host and seeing that the deployment is succeed.

    I can ping the ip addr of BGPNAT-VM but get no response from the host machine. 

    I'm not sure if I clearly describe the problem, but really wonder if anyone can help.

    Monday, October 23, 2017 11:23 AM

Answers

  • Hello Evelyne,

    You are correct. Your ASDK-Host and Jumpbox should not be on any of the following Networks.

        

    Depending on how you subnet, the 192.168.0.0 private IP range can accommodate several thousand networks with thousand of nodes on each network. 6 of the several 1000’s of networks available are reserved for the internal networks within the ASDK.

     

    Do not connect the development kit machine to the following subnets.

    •192.168.200.0/24

    •192.168.100.0/27

    •192.168.101.0/26

    •192.168.102.0/24

    •192.168.103.0/25

    •192.168.104.0/25

    These subnets are reserved for the internal networks within the development kit environment.

    From https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-deploy#network

    See Network for details

         

    I speak with our Networking Team if there is a workaround I can suggest.

     

    Here’s the output from my TNC in my environment.

    PS C:\WINDOWS\system32> tnc 10.184.224.16 -port 3389

     

    ComputerName     : 10.184.224.16

    RemoteAddress    : 10.184.224.16

    RemotePort       : 3389

    InterfaceAlias   : MSFTVPN

    SourceAddress    : 10.10.93.114

    TcpTestSucceeded : True

     

    Let us know how it goes

         

    We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

    If you continue experience any issues with the ASDK release, feel free to contact us.

         

     Thanks


    Gary Gallanes

    Thursday, November 30, 2017 6:17 PM
    Moderator

All replies

  • Are you running these VM's on Azure Stack? Could you provide more details?

    -----------------------------------------------------------------------------------------------------------------------------------
    Do click on "Mark as Answer" on the post that helps you and vote it as helpful, this can be beneficial to other community members.

    Tuesday, October 24, 2017 2:54 AM
    Moderator
  • Yes of course. I can access to the ASDK host via a console tool (iLO), but cannot access directly via windows RDP. 

    Tuesday, October 24, 2017 11:25 AM
  • Evelyne,

    While your logged in under ILO, can you do an Ipconfig on your Host and verify the IP you are attempting to RDP into?

    If you are using DHCP, your IP address my have updated after booting into CloudBuilder.vhdx.

    Once you've got the IP, run the following from your remote computer to test your connection to the Host on port 3389.

    Example using my ASDK-Host IP address '10.177.170.65 ' from my remote laptop.

    tnc 10.177.170.65 -port 3389

    The output should something look like this:

    ComputerName     : 10.177.170.65
    RemoteAddress    : 10.177.170.65
    RemotePort       : 3389
    InterfaceAlias   : MSFTVPN
    SourceAddress    : 10.10.93.114
    TcpTestSucceeded : True

    CloudBuilder.vhdx boots with RDP enabled by default so no firewall or other services need to be enabled. Let us know how the network test goes.

     Thanks,


    Gary Gallanes


    Wednesday, October 25, 2017 1:29 AM
    Moderator
  • Sorry for the late reply.

    I am using static IP so the IP address won't change.

    I identified the IP address and tested what you suggested but the output was "false".

    Is it because of the "VLAN" setting? My network administrator set the VLAN of my ASDK host on switch side directly. It worked fine before I finally succeeded in the deployment while I don't know why it doesn't work after the deployment.

    Sunday, November 12, 2017 12:29 PM
  • Hi Evelyne

    I had the same problem with the VLAN after the deployment. My solution was to configure the VLAN ID directly in the Configuration of the Virtual Switch (visible in the HyperV Manager) named "PublicSwitch".

    Andre

    Tuesday, November 14, 2017 11:39 AM
  • Hello Evelyne,

    It looks like the PC you using to to access the Azure Stack Host on (RDP-3389)  is one a subnet that is reserved for Azure Stack.

       

    Your SOURCE ADDRESS: 192.168.102.16

     

    From https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-deploy#network

    Do not connect the development kit machine to the following subnets.

    •192.168.200.0/24

    •192.168.100.0/27

    •192.168.101.0/26

    •192.168.102.0/24

    •192.168.103.0/25

    •192.168.104.0/25

    These subnets are reserved for the internal networks within the development kit environment.

      

    See Network for details

      

    We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

    If you continue experience any issues with the ASDK release, feel free to contact us.

           

     Thanks


    Gary Gallanes

    Thursday, November 16, 2017 7:04 PM
    Moderator
  • I tried your suggestion but the host lost network connection after I set the VLAN ID on Virtual Switch Manager..

    Cloud you show me the "tnc" output on your system?

    Friday, November 17, 2017 1:32 AM
  • This jump host's network range is used by my company's whole network system so I am afraid I can't ask the administrator to change it.

    But I haven't deployed ASDK on this range, but choosing a range at "192.168.201.0/25". Do you mean that whatever jump host or the ASDK host, neither of them should be put in the above reserved range?

    Friday, November 17, 2017 1:35 AM
  • Hello Evelyne,

    You are correct. Your ASDK-Host and Jumpbox should not be on any of the following Networks.

        

    Depending on how you subnet, the 192.168.0.0 private IP range can accommodate several thousand networks with thousand of nodes on each network. 6 of the several 1000’s of networks available are reserved for the internal networks within the ASDK.

     

    Do not connect the development kit machine to the following subnets.

    •192.168.200.0/24

    •192.168.100.0/27

    •192.168.101.0/26

    •192.168.102.0/24

    •192.168.103.0/25

    •192.168.104.0/25

    These subnets are reserved for the internal networks within the development kit environment.

    From https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-deploy#network

    See Network for details

         

    I speak with our Networking Team if there is a workaround I can suggest.

     

    Here’s the output from my TNC in my environment.

    PS C:\WINDOWS\system32> tnc 10.184.224.16 -port 3389

     

    ComputerName     : 10.184.224.16

    RemoteAddress    : 10.184.224.16

    RemotePort       : 3389

    InterfaceAlias   : MSFTVPN

    SourceAddress    : 10.10.93.114

    TcpTestSucceeded : True

     

    Let us know how it goes

         

    We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

    If you continue experience any issues with the ASDK release, feel free to contact us.

         

     Thanks


    Gary Gallanes

    Thursday, November 30, 2017 6:17 PM
    Moderator
  • Thank you for the reply. Since the jump host's IP address cannot be changed, my network admin has set another port on the ASDK host thus allow me to RDP into the AzS desktop.

    Maybe it is not a traditional way, but until now it helped.

    Wednesday, December 06, 2017 1:55 AM