locked
Why can't I log into my "Local" sql server (sql server 2014) with my Sql Server Authentication UID ? RRS feed

  • Question

  • I just got a new work station (win7 Pro) which has the following sql server

    SELECT SERVERPROPERTY('productversion'), SERVERPROPERTY ('productlevel'), SERVERPROPERTY ('edition')

    returns

    12.0.2254.0     RTM     Developer Edition (64-bit)

    Select @@version

    returns

    Microsoft SQL Server 2014 - 12.0.2254.0 (X64)
     Jul 25 2014 18:52:51
     Copyright (c) Microsoft Corporation
     Developer Edition (64-bit) on Windows NT 6.1 <X64> (Build 7601: Service Pack 1)

    I added/created a new (random) user account to this server [joe123] and made him sa and mapped him to everything, the password never expires, ...

    when I try to login to this local server the login fails, but I can log into this server with my windows integrated account (also sa).  What do I need to do so that the joe123 account can login to the server


    Rich P

    Friday, September 12, 2014 5:42 PM

Answers

  • Check if both "SQL Server and Windows Authentication mode" is set (not just Windows Authentication mode). Server-->right click and select properties -->  Security

    Satish Kartan http://www.sqlfood.com/

    • Marked as answer by Rich P123 Friday, September 12, 2014 6:13 PM
    Friday, September 12, 2014 6:01 PM
  • Thank you.  It was sent to only Windows Authentication.  I changed it to Sql Authentication and Windows Authentication option.  Now I can log in as joe123 (yay! :)

    Many Thanks


    Rich P

    Friday, September 12, 2014 6:14 PM

All replies

  • Check if both "SQL Server and Windows Authentication mode" is set (not just Windows Authentication mode). Server-->right click and select properties -->  Security

    Satish Kartan http://www.sqlfood.com/

    • Marked as answer by Rich P123 Friday, September 12, 2014 6:13 PM
    Friday, September 12, 2014 6:01 PM
  • Thank you.  It was sent to only Windows Authentication.  I changed it to Sql Authentication and Windows Authentication option.  Now I can log in as joe123 (yay! :)

    Many Thanks


    Rich P

    Friday, September 12, 2014 6:14 PM