none
Bing Map Aerial Mode, Lables change bar not working, If I am using 2 Map controls at a Time. RRS feed

  • Question

  • Hi,

    I am loading Bing map control in two different divs, in same page, for map type Aerial, when I am trying to switch off/On show labels on map,  Swich On/Off button CSS is not working for one of the map control in the page.

    please find below screen shot.

    For Map 2, I switched off the map labels, but still button is on On mode.

    

    Thanks,

    Gowind

    Monday, January 9, 2017 3:03 PM

Answers

  • There are a number of known issues that occur when rendering multiple maps on the same page. These issues have since been resolved in the experimental branch, but have not yet been released into the main release branch due to a holiday code freeze. I've just tried the experimental branch and was unable to reproduce the issue you are reporting. The main release branch should be updated with all the bug fixes that are in the experimental branch in the next week or two. If you want to try this now, add "&branch=experimental" to the map script URL.


    [Blog] [twitter] [LinkedIn]

    • Proposed as answer by Ricky_Brundritt Monday, January 9, 2017 4:46 PM
    • Marked as answer by Gowind_ Tuesday, January 10, 2017 7:06 AM
    Monday, January 9, 2017 4:46 PM
  • I'll log that as a bug. Given the minor difference it likely will be marked as low priority and take some time before the team looks into it.

    [Blog] [twitter] [LinkedIn]

    Tuesday, January 10, 2017 5:23 PM

All replies

  • There are a number of known issues that occur when rendering multiple maps on the same page. These issues have since been resolved in the experimental branch, but have not yet been released into the main release branch due to a holiday code freeze. I've just tried the experimental branch and was unable to reproduce the issue you are reporting. The main release branch should be updated with all the bug fixes that are in the experimental branch in the next week or two. If you want to try this now, add "&branch=experimental" to the map script URL.


    [Blog] [twitter] [LinkedIn]

    • Proposed as answer by Ricky_Brundritt Monday, January 9, 2017 4:46 PM
    • Marked as answer by Gowind_ Tuesday, January 10, 2017 7:06 AM
    Monday, January 9, 2017 4:46 PM
  • Hi Ricky,

    Thanks for quick response, I tested with Experimental branch, CSS is working fine, but found small observation that, on click of Labels button, its immediately closing the map types drop down for one of the map in the page. for other one its working fine.

    Thanks,

    Gowind

    Tuesday, January 10, 2017 7:10 AM
  • I'll log that as a bug. Given the minor difference it likely will be marked as low priority and take some time before the team looks into it.

    [Blog] [twitter] [LinkedIn]

    Tuesday, January 10, 2017 5:23 PM