locked
Installing SQL Server 2005 Developer Edition (64 bit) on Windows 7 Home Premium (64 bit) RRS feed

  • Question

  • Hello All,

    I would like to know if I can install SQL Server 2005 Dev Edition (64 bit) on Windows Home Premium (64 bit)? I have enabled the IIS via the control panel. Is there anything else that I need to do before I start the installation? Please assist.

    Thanks,

    CD

    Friday, February 26, 2010 4:20 PM

Answers

  • Enable .Net 3.5 from "Turn Windows Features on or off " and then you are ready to go.

    Dont forget to Apply SQL Server SP3 once installation is completed.
    Friday, February 26, 2010 6:23 PM
  • Hi,

    For installing SQL Server 2005, most of the system software requirements are satisfied on Windows 7 (or you need to turn on some features of them). You should be able to perform the installation, after installation, please apply SP3 for SQL Server 2005 which is required for running SQL Server 2005 on Windows 7 or Windows Server 2008 R2.

    More information:
    Hardware and Software Requirements for Installing SQL Server 2005
    Chunsong Feng
    Microsoft Online Community Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, March 2, 2010 8:25 AM

All replies

  • Enable .Net 3.5 from "Turn Windows Features on or off " and then you are ready to go.

    Dont forget to Apply SQL Server SP3 once installation is completed.
    Friday, February 26, 2010 6:23 PM
  • Hi,

    For installing SQL Server 2005, most of the system software requirements are satisfied on Windows 7 (or you need to turn on some features of them). You should be able to perform the installation, after installation, please apply SP3 for SQL Server 2005 which is required for running SQL Server 2005 on Windows 7 or Windows Server 2008 R2.

    More information:
    Hardware and Software Requirements for Installing SQL Server 2005
    Chunsong Feng
    Microsoft Online Community Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, March 2, 2010 8:25 AM
  • Hi,

    I am trying to install SQL Server 2005 on Win 7 x64 as well. I managed to run the Setup and installed the RTM version successfully. I  installed the DB engine and SSRS.

     

    When I tried to apply SP3, it failed at the SP3 setup authentication stage.

    Login succeeded for DB engine, but failed for SSRS.

    Error message as follows :

    HResult 0xFFFFFFFF, Level 16, State 1 SQL Network Interfaces: Error Locating Server/Instance Specified [xFFFFFFFF].  Sqlcmd: Error: Microsoft SQL Native Client : An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections.. Sqlcmd: Error: Microsoft SQL Native Client : Login timeout expired.

     

    I used Windows Authentication. I have tried using SQL authentication as well - but I got the same error.

    Please advice.

    Thanks.

    Sunday, September 12, 2010 9:26 AM
  • Hi there,

    I have solved the problems stated in my earlier post. Here's what I did :

    1. Download and install the latest SQL Native Client ( I installed SNAC from Cumulative Update 11 for SP3 ).
    2. Run SP3 setup, select to everything except server instance features ( this skips the Authentication ).
    3. Run SQL User Provisioning Tool ( C:\Program Files (x86)\Microsoft SQL Server\90\Shared\SqlProv.exe ) as elevated admin.
    4. Add my currently logged in account ( a local admin account ) as SQL admin.
    5. Open services.msc and start both SQL DB engine and SSRS services.
    6. Run SP3 setup again. This time authentication will succeed.
    7. Before proceeding with setup, shut down both services that were started in step 5. (This is done so that no restart is needed at the end of setup ).
    8. Click Next and proceed with SP3 Setup.

    In my case, SP3 was applied successfully. I even went on to apply the latest CU.

    Hope this helps someone.

    Thanks.

    • Proposed as answer by ViperXP Sunday, September 12, 2010 2:39 PM
    Sunday, September 12, 2010 2:39 PM