locked
SQL 2005 Cube issue in Excel Pivot (Regular not Power) Table RRS feed

  • Question

  • We had a cube/pivot where the user could see Grand Total as she/he wished ... meaning Include Filtered Items or Not Include filtered items in totals when they had Excel 2007

    The front end has been upgraded to 2010, Include filtered items in totals is grayed out. I think Office upgrade is the only event that happened to cause such a problem. We are not 100% sure.

    The problem is right here: From the Pivot the PivotTable Options (right mouse click) | Totals & Filters (tab) | Filters (section) | Include filtered items in totals (checkbox) grayed out.

    Again this is not a PowerPivot issue, but people here might have seen this behavior before.

    We tried everything .... Show calculated members from OLAP server, or Save As ".xls" or backword compatible version .... copy/paste the Pivot table into other Excel workbooks.... but nothing has worked.

    Friday, December 2, 2011 6:41 PM

Answers

  • Hi Cornelia,

    I try to reproduce this scenario in both PowerPivot 1.0 and 2.0, but they all work very well, it seem there is some limitation that we cannot reproduce it, the issue might only occurs in the specific environment, here I would recommend you open a bug ticket at this link https://connect.microsoft.com/SQLServer/Feedback This connect site is a connection point between you and Microsoft. Your feedback enables Microsoft to make software and services the best that they can be. Also you can get more prompt replies from the Connect team directly.

    Or if the issue is quite urgent, we would recommend the customer go to http://support.microsoft.com for some prompt support.

    If you have any additional questions or feedbacks regarding this thread, please feel free to let us know.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Challen Fu Monday, December 19, 2011 2:21 AM
    Tuesday, December 13, 2011 6:51 AM
  • We solved the problem.  The Cube at the server (SQL 2005) was upgraded/moved to 2008 R2 and the

    Filters (tab) | Filters (section) | Include filtered items in totals (checkbox) NOT grayed out anymore.

    It was working fine with SQL 2005 and Office 2007

    With Office  2010 + SQL 2005  it was grayed out.

    With Office 2010 + SQL 2008 it is working fine now.

    Case closed ... it was a strange transition bug.

     

    • Marked as answer by Challen Fu Friday, December 23, 2011 1:19 AM
    Thursday, December 22, 2011 7:33 PM

All replies

  • Hi CorneliaGibbs,

    To this issue, I would recommend you install the latest Services Package to have a try, SP1 is available at this link http://www.microsoft.com/download/en/details.aspx?id=26622 

    If the issue still exist, could you please upload your workbook at http://skydriver.live.com/ to show us your issue, it will be better if you can paste your issue snapshot to demonstrate clearly.

    Regards,
    Challen Fu


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, December 6, 2011 3:05 AM
  • Hi Challen Fu

    Strangely enough, I already had SP1 installed on the machine with Office 2010.
    It behaves same with (with Include filtered items in totals grayed out), even though the OLAP values are coming from the server or not.
    Tried almost all combinations, that checkbox (and the one right below) is always grayed out.
    75% chance that it was working with Office 2007, but we are not sure.

    I could not share the files anonymously in skydrive, so has put them on a web server.
    http://www.humangenome.org/ToolbarFilters.jpg
    http://www.humangenome.org/display.jpg

    Very strange, so many viewes on the issue .... looks like it did not happen to anybody else.

    Thanks / Cornelia

     

    Tuesday, December 6, 2011 9:55 PM
  • Hi Cornelia,

    I try to reproduce this scenario in both PowerPivot 1.0 and 2.0, but they all work very well, it seem there is some limitation that we cannot reproduce it, the issue might only occurs in the specific environment, here I would recommend you open a bug ticket at this link https://connect.microsoft.com/SQLServer/Feedback This connect site is a connection point between you and Microsoft. Your feedback enables Microsoft to make software and services the best that they can be. Also you can get more prompt replies from the Connect team directly.

    Or if the issue is quite urgent, we would recommend the customer go to http://support.microsoft.com for some prompt support.

    If you have any additional questions or feedbacks regarding this thread, please feel free to let us know.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Challen Fu Monday, December 19, 2011 2:21 AM
    Tuesday, December 13, 2011 6:51 AM
  • Hi Challen,

    It was not a PowerPivot issue the RegularPivot... but I will post it to Connect.... not sure it will make a difference.

    Thank you for kind help

    Wednesday, December 14, 2011 4:05 AM
  • Sorry for misunderstanding your scenario, even if it is RegularPivottable, I can click the checkbox in local environment, this is the Forum for PowerPivot, to your question, you should post it at Excel forum at this link http://answers.microsoft.com/en-us/office/forum 

    Thanks,
    Challen Fu


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, December 14, 2011 4:56 AM
  • We solved the problem.  The Cube at the server (SQL 2005) was upgraded/moved to 2008 R2 and the

    Filters (tab) | Filters (section) | Include filtered items in totals (checkbox) NOT grayed out anymore.

    It was working fine with SQL 2005 and Office 2007

    With Office  2010 + SQL 2005  it was grayed out.

    With Office 2010 + SQL 2008 it is working fine now.

    Case closed ... it was a strange transition bug.

     

    • Marked as answer by Challen Fu Friday, December 23, 2011 1:19 AM
    Thursday, December 22, 2011 7:33 PM