"Updating Microsoft Office" followed by error message RRS feed

  • Question

  • User-431989064 posted

    This is a bit complex so bear with me. Using VS2012 for development of a .NET application that serves as a front end to a SQL Server database. Because we use Windows Authentication for the database, and because that account is different than my personal account. I launch Visual Studio as another user (the SQL Server account) in order to do my development. My application has tools to export data to Excel. Whenever I attempt an Excel export while in Debugging mode, I get an "Updating Microsoft Office" splash screen and then after a few minutes an error message saying "The application was unable to start correctly" with error code 0xc0000142. This only happens when working in debugging mode. If I publish my website, the Excel exports work just fine in both production and non-production environments. I have no other issues opening Excel or any other Office applications. Office version is 2016. OS is Windows 10. I have checked the relevant folders and both my account and the SQL Server account have Full Control permissions. Any thoughts? Could this be an Office licensing issue somehow related to the use of the two accounts?

    Tuesday, July 28, 2020 5:50 PM


  • User-431989064 posted

    I now believe this is a user/licensing problem with Office 2016. I just tried starting Excel (outside of Visual Studio) as the other user and I got the same error. This question can be closed.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, July 28, 2020 7:12 PM