locked
Dependency on .Net 4.5 RRS feed

  • Question

  • I noticed that there is a dependency on .Net 4.5. Is this a hard dependency and what functionality does it impact. 
    Monday, November 26, 2012 7:43 PM

Answers

  • Thank you for pointing us to this confusion. We will fix MSDN shortly.

    You client can use .NET 4.0 PU3 or 4.5.

    regards,

    Ziv, Windows Azure Service Bus team

    Wednesday, November 28, 2012 7:28 PM

All replies

  • Service Bus 1.0 requires that "Update 4.0.3 for Microsoft .NET Framework 4" is installed. It will also work if .Net 4.5 is installed.

    If you do not have Update 4.0.3 for .Net 4 installed Web Platform Installer will list .Net 4.5 in the prerequisites.

    Thanks,

    Amit

    Wednesday, November 28, 2012 12:04 AM
  • Is 4.0.3 a supported configuration with MS Support, etc?  

    Documentation suggests it's not a supported option for production use:

    The Service Bus for Windows Server is built on the Microsoft .NET Framework 4.5 PU3, Windows Server 2008 R2, SQL Server 2008 R2 and SQL Database, and Windows PowerShell 3.0. All these platforms must be running on a 64-bit operating system. 

    http://msdn.microsoft.com/en-US/library/jj193012(v=azure.10).aspx


    • Edited by cromwellryan Wednesday, November 28, 2012 6:10 PM spelling error and emphasizing supported
    Wednesday, November 28, 2012 5:41 PM
  • Thank you for pointing us to this confusion. We will fix MSDN shortly.

    You client can use .NET 4.0 PU3 or 4.5.

    regards,

    Ziv, Windows Azure Service Bus team

    Wednesday, November 28, 2012 7:28 PM
  • 4.0.3 and 4.5 are supported. This was an error in documnentation. Thanks for pointing it out.

    We have fixed the documentation.

    Thanks,

    Amit

    Wednesday, November 28, 2012 7:29 PM