locked
Newly Created VS Solution with ads is broken

    Question

  • I have generated a new App Studio app for the first time and opening it in a fresh install of Visual Studio 2015 Community edition Update 3 it is broken. I install Microsoft Services SDK (https://visualstudiogallery.msdn.microsoft.com/229b7858-2c6a-4073-886e-cbb79e851211/) to serve ads and I get the error

    Error  Could not find SDK "Microsoft.AdMediator.Universal, Version=1.0". 

    Should this not work out of the box for a brand new App Studio app?


    C# Professional

    Saturday, September 24, 2016 4:34 AM

All replies


  • Hi Lars,
    Could you please tell us which AD control are you using? The AdControl or AdMediatorControl ?
    As far as I’m concerned, you cannot use AdMediatorControl in the UWP app and you can refer to this link.

    If you used the AdControl in your UWP app, you can refer to the following steps:
    1.Please install Microsoft Store Services SDK
    2.In Visual Studio, open your project or create a new project
    3.From the Solution Explorer window, right click References, and select Add Reference
    4.In Reference Manager, Expand Universal Windows, click Extensions, and then select the check box next to Microsoft Advertising SDK for XAML (Version 10.0).

    5.In Reference Manager, click OK
    6.Add the namespace reference Microsoft.Advertising.WinRT.UI


    For more details about AdControl you can refer here.

    If you used AdMediatorControl in your windows and windows phone 8.x, please check the following steps:
    1.Please install Microsoft Advertising SDK for windows and windows phone 8.x
    2.In Visual Studio, open your project or create a new project
    3.From the Solution Explorer window, right click References, and select Add Reference
    4.In Reference Manager, Expand Windows 8.1, click Extensions, and then select the check box next to Ad Mediator SDK for Windows 8.1 XAML

    5.In Reference Manager, click OK
    6.Add the namespace reference Microsoft.AdMediator.Windows81

    To configure the ad networks:
    1.From the Solution Explorer window, right click References, and select Add connected service
    2.click Ad Mediator and then click Configure to open the Ad Mediator window

    3.click Select ad networks, select the ad networks you want to use, and click OK in the Select ad networks window.

    4.In the Ad Mediator (Visual Studio 2015), click Configure to enter the configuration information for each network to use while testing the app.
    More details about AdMediator you can refer to this .

    Best Regards,

    Neal Wang


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, September 26, 2016 11:21 AM
    Moderator
  • Hi Neal

    I have the same problem in my Project and as you can see in the image below the "Microsoft Advertising Universal SDK" is with a triangule and the Resolved field is = false. I'm using the ad enable provide by App Studio website, already did all the suggestions above you mentioned earlier and it didn't solved.

    Any more suggestions?

    Tuesday, September 27, 2016 11:19 AM
  • Hi Arcturus Gonzalez,

    Base on your screenshot,  it seems that you have some errors by downloading your source code and open it in Visual Studio. Firstly you could remove “Microsoft Advertising Universal SDK” from Reference and then  install Microsoft Advertising SDK, right click Reference and choose Add Reference, Expand Universal Windows, click Extensions, and then select the check box next to Microsoft Advertising SDK for XAML.

    And you could modify your code in visual studio, the ApplicationId and AdUnitId you could go to the Dashboard to apply. if you want to freshen ads , you could set the property ”IsAutofreshEnabled=True”

    <UserControl
        x:Class="Cherry001.Layouts.Controls.AdvertisingControl"
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"    
        xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
        xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"	
        xmlns:Universal="using:Microsoft.Advertising.WinRT.UI"
       
        DataContext="{Binding RelativeSource={RelativeSource Self}}"
        mc:Ignorable="d"
        d:DesignHeight="300"
        d:DesignWidth="400">
        <Grid Background="#dddddd" Margin="0,24,0,24">
            <Grid Margin="24,24,24,24">
                <Universal:AdControl x:Name="adControl1" IsAutoRefreshEnabled="True" Width="{x:Bind BannerWidth}" Height="{x:Bind BannerHeight}" ApplicationId="3f83fe91-d6be-434d-a0ae-7351c5a997f1" AdUnitId="10865270"  HorizontalAlignment="Center"/>
                
            </Grid>
        </Grid>
    </UserControl>
    

    Best Regards,

    Cherry Bu

    Thursday, September 29, 2016 7:08 AM
    Moderator
  • Hi Cherry

    It didn't wort out. Later tonight I will share my screenshot with you.

    Regards

    Arcturus

    Tuesday, October 4, 2016 11:57 AM
  • Hi Arcturus Gonzalez,

    @Arcturus Gonzalez Could you share your the screenshot about the AdControl's error with me? and then I will try my best to solve it . Thank you!

    Best Regards,

    Cherry Bu.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, October 10, 2016 8:27 AM
    Moderator
  • Like the above question, isn't this supposed to work out of the box when the Windows 10 app I made on App Studio was made for me and all I did was download the source code? Try to keep in mind that this is going on for people with little experience with code and we aren't as good as you are with modifying code so easily.

    I just don't understand how this is an issue and I can't find a solution anywhere.

    Saturday, July 8, 2017 6:21 PM
  • I've had the same error and I've been asking for help about it for weeks but I don't get much of a response :( I wish MSFT would provide more help to those who are here and trying to help.

    https://social.msdn.microsoft.com/Forums/windowsapps/en-US/7dea9d66-6904-460c-9a4c-e4dfb00a6811/download-source-code-try-to-debug-advertising-sdk-references-dont-exist?forum=wpappstudio 

    The link shows my post and screenshots of this same exact issue. Make an app with ads, publish it on store, see it live and well, download source code.

    Friday, July 14, 2017 3:10 PM
  • https://social.msdn.microsoft.com/Forums/windowsapps/en-US/7dea9d66-6904-460c-9a4c-e4dfb00a6811/download-source-code-try-to-debug-advertising-sdk-references-dont-exist?forum=wpappstudio

    Same exact error and screenshots I've been hoping to get some answers on before AppStudio is gone and I lose my chance at having an app.

    Friday, July 14, 2017 3:12 PM