locked
Configure IIS 7 to handle ASP framework with appcmd.exe RRS feed

  • Question

  • User-1292553911 posted

     I need to use appcmd to configure IIS 7 to handle ASP framework. When I use the following command:

    c:\Windows\System32\inetsrv>appcmd set config -section:IsapiCgiRestriction /+[path='%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll',allowed='true',groupId='ASP.NET v2.0.5072',description='ASP.NET v2.0.50727']

    Then I got the following errors:

    Failed to process input: The parameter 'v2.0.50727']' must begin with a / or - (HRESULT=80070057).

     It's appreciated for any idea.

     
     

     

    Friday, March 21, 2008 3:41 AM

Answers

  • User511787461 posted

    Again standard parsing of input will split input parameter on a space - you need to surround the whole parameter with double quotes to prevent that

    appcmd set config -section:IsapiCgiRestriction "/+[path='%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll',allowed='true',groupId='ASP.NET v2.0.5072',description='ASP.NET v2.0.50727']"

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, March 24, 2008 1:35 PM

All replies

  • User511787461 posted

    You need to type in \\ when you want \ - standard command line escaping rules.

    Friday, March 21, 2008 12:02 PM
  • User-1292553911 posted


    Anilr, thanks for you answer. When I replace \ with \\, the same problem happens. It seems that the space in description syntax "ASP.NET v2.0.50727" causes the problem. When I remove the spaces from groupId and decription syntax, this kind of error is removed. It's confusing.

    I work on 64 bit Vista.
     


     

     


     

    Sunday, March 23, 2008 10:47 PM
  • User511787461 posted

    Again standard parsing of input will split input parameter on a space - you need to surround the whole parameter with double quotes to prevent that

    appcmd set config -section:IsapiCgiRestriction "/+[path='%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll',allowed='true',groupId='ASP.NET v2.0.5072',description='ASP.NET v2.0.50727']"

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, March 24, 2008 1:35 PM