none
Can't renew developer license RRS feed

  • Question

  • I'm using Visual Studio Express 2013 to create a Store app. I'm getting this error.

    Error 6 Error : DEP0100 : Deployment failed due to a Developer Licensing issue.
    Could not obtain a developer license because the licensing server could not be contacted.  Please ensure you have an active connection to the Internet and try again.

    However, I'm quite sure I have an internet connection. Any thoughts? Thanks!

    Chuck

    Friday, June 5, 2015 11:33 PM

Answers

  • Hi,

    You should be able to get a developer license via running PowShell command with Administrator (in case you don't have Visual Studio installed) if you have an internet connection. (PS command: Show-WindowsDeveloperLicenseRegistration)

    I saw that you mentioned in your initial post that you have an active internet connection, however, I still think it worth to have a double check on it. And do you connect to the Internet via proxy server?

    Thanks.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, June 18, 2015 6:37 AM
    Moderator

All replies

  • Hi Chuck,

    You can renew a developer license whenever you're using the Visual Studio IDE. And you're using Microsoft Visual Studio Express 2013 for Windows, choose Store, Acquire Developer License on the menu bar to renew a developer license. Refer to the following link for detail information: https://msdn.microsoft.com/en-us/library/windows/apps/hh974578.aspx?f=255&MSPPError=-2147217396

    Hope this information is helpful.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, June 8, 2015 5:46 AM
    Moderator
  • Hi Jiayi,

    Yes, I have seen this post you included. The problem is that when I run the command to get my license, I am getting the error I mentioned above. Any ideas on how to fix that?

    Thanks,

    Chuck

    Monday, June 8, 2015 12:04 PM
  • Hi Chuck,

    What’s the OS version of your computer? I found this same issue on this link: https://connect.microsoft.com/VisualStudio/feedback/details/762946/cannot-request-offline-developer-license-for-visual-studio-2012-windows-store-app#tabs  

    And I found one solution from this page: http://visualstudio.uservoice.com/forums/121579-visual-studio/suggestions/3165766-allow-development-of-windows-store-apps-offline-

    You can try the following method have a try:

    This is fixed in Windows 8.1 RTM and a new hotfix for Windows 8: http://support.microsoft.com/kb/2871280
    However, you need to enable these Group Policy settings to allow offline development:
    Computer configuration\Administrative Templates\Windows Components\App Package Deployment\Allow all trusted apps to install
    Computer configuration\Administrative Templates\Windows Components\App Package Deployment\Allow development of Windows Store apps without installing a developer license.
    You also may need to be joined to a domain to use this since MS considers this to be an enterprise feature.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Wednesday, June 10, 2015 6:41 AM
    Moderator
  • Hi,

    I'm running "normal/non-pro" Windows 8.1. It would really stink if MS restricted indy developers from using this.

    I've been a bit distracted from this, but I will look over your links. The one seemed to have quite a few different responses, this may take a while.

    Thanks for your time and help!

    Chuck

    Friday, June 12, 2015 10:14 PM
  • Hi Chuck,

    You can try the following method to have a try:
    This is fixed in Windows 8.1 RTM and a new hotfix for Windows 8: http://support.microsoft.com/kb/2871280
    However, you need to enable these Group Policy settings to allow offline development:
    Computer configuration\Administrative Templates\Windows Components\App Package Deployment\Allow all trusted apps to install
    Computer configuration\Administrative Templates\Windows Components\App Package Deployment\Allow development of Windows Store apps without installing a developer license.
    You also may need to be joined to a domain to use this since MS considers this to be an enterprise feature.

    Please remember to send the feedback to us.

    Best Regards,
    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, June 15, 2015 9:08 AM
    Moderator
  • I'll look at this again, but I am doing this all from home so I can't join a domain.

    Thanks...

    Monday, June 15, 2015 12:14 PM
  • I requested the hotfix, but I am hesitant to install it. The write-ups amke a big deal of not installing fixes that aren't intended for your system. My system can not join a domain, so I don't think I can install it.

    Also, I do not know how to get to the 

    Computer configuration\Administrative Templates\Windows Components\App Package Deployment\Allow all trusted apps to install 
    Computer configuration\Administrative Templates\Windows Components\App Package Deployment\Allow development of Windows Store apps without installing a developer license. 

    options to set them? Again, I don't I can do so without being joined to a domain (or, at least not without having Windows 8.1 Pro version).

    Does this sound correct to you? Thanks!!!

    Monday, June 15, 2015 9:25 PM
  • Hi Chuck,

    You can type “gpedit.msc” in the Run to launch the Local Group Policy Editor, and navigate to:

    Computer configuration\Administrative Templates\Windows Components\App Package Deployment\Allow all trusted apps to install
    Computer configuration\Administrative Templates\Windows Components\App Package Deployment\Allow development of Windows Store apps without installing a developer license.

    And right click it, you will see the following picture, and enable it:

    You can try it first, and if it doesn’t help, you may need to have the professional version.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Tuesday, June 16, 2015 6:09 AM
    Moderator
  • 'gpedit.msc' is not recognized as an internal or external command, operable program or batch file

    Remember, I'm plain Windows, not Pro...

    Tuesday, June 16, 2015 12:11 PM
  • Hi,

    You should be able to get a developer license via running PowShell command with Administrator (in case you don't have Visual Studio installed) if you have an internet connection. (PS command: Show-WindowsDeveloperLicenseRegistration)

    I saw that you mentioned in your initial post that you have an active internet connection, however, I still think it worth to have a double check on it. And do you connect to the Internet via proxy server?

    Thanks.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, June 18, 2015 6:37 AM
    Moderator
  • Aha! That was it, running the command as Administrator. Thanks very much, Vicky! :-)

    I've got to boo MS for the misleading error message. Of course I had an internet connection, I was able to post the problem to this website, right? Oh well, it only set me back 3 weeks.


    Thursday, June 18, 2015 12:17 PM