NSTutorial Service won't start RRS feed

  • Question

  • I can't get my NSTutorial service to start.  I've edited the ICF as per the Walkthru, and everything seems fine.  The app

    registers successfully, the Service Account is set up and can access the databases and read / write  to the proper

    Notifications directories.  However when I enable the service, and press Start, it simply gives the following message:

    Windows services for instance - Tutorial

     Time out has expired and the operation has not been completed. (System.ServiceProcess)

    If I try and start the service thru Service Manager, I get the following error:

    Error 1359: An internal error occurred.

    If I try and start the service from the command line I get a similar error 1359.

    I'm running a named instance SQL Server 2005 (SP1), don't know if that's causing a problem, and I don't have IIS

    installed - that may also cause a problem.  The service account is a local account with User and Admin privileges.  I'm

    able to logon as the service account and access the databases and the proper NS directories.  Bit stuck!  Any ideas?



    Monday, October 23, 2006 4:58 PM

All replies

  • In your ICF and ADF, you're pointing to the named instance of SQLNS 2005? What about when you registered it?

    When I see a timeout starting the service, the first thing that comes to mind is permission issue. May want to double/triple check that. Maybe even try it using sa?




    Tuesday, October 31, 2006 1:55 PM
  • I've got the same problem, but I'm not using a demo configuration, instead it's an upgraded sql-ns 2.0 configuration that has ran for over a year!


    I'm running this as an admin level user, so that's not the problem.


    Please help,




    Wednesday, May 16, 2007 10:07 PM
  • Hi Marcus -

    When you say you've upgraded the v2.0 instance to v2005, did you go through the upgrade process as described in BOL and in this article?



    Wednesday, May 23, 2007 11:57 AM
  • Hi,

       Huh, I don't know either what the problem is. I haven't figured out, although on my home computer everything had been succesfully installed, but on another one, I get that internal error 1359 while running service process


    Has anyone of you ever had that problem, what can i check to fix it?


    Really thanks


    Monday, July 16, 2007 10:47 AM
  • Hi,


    I realize the original is an old post, but FWIW, I was getting the same error and was able to resolve it by specifying a local rather than a network path when registering and pointing to the ICF file (instead of a path that starts with \\ServerName, use something like C:\Documents and Settings\ProjectFolder\ProjectFile.xml)


    Hope that helps,



    Saturday, July 28, 2007 9:34 PM
  • This is a reply to Xor2:

    I had a similar same problem (although I do not remember the error number): my NS app was working on my home machine, but didn't work on my computer at work.

    1. The only difference was that I had a SQL Server 2005 Developer Edition (my own copy) at home, and Trial Edition at work.

    As soon as I installed a Dev edition at work (my boss was really surprised why I didn't ask him for Dev Edition CD ), this problem disappeared.

    Please note that this was before Service Pack 1 [the current version of SP is 2], so maybe this issue was resolved in one of those two Service Packs...

    2. Another possible reason for the same app to run on one machine and not on the other is the difference in environment.
    You haven't mentioned what version of NS you're using: NS 2.0 (for SQL Server 2000) or NS for SQL Server 2005.

    If it's NS 2.0 (SQL Server 2000 Notification Services - a free addition to SQL Server 2000 Dev/Standard/Enterprise editions), please look at this post: http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1808151&SiteID=1

    Also (albeit this is very unlikely to be the cause of your problem), if you are using SQL NS 2.0, please note that NS 2.0 comes in 2 editions: for SQL Server 2000 Standard and Enterprise editions respectively. Make sure you're using the correct one.

    Friday, August 3, 2007 12:23 PM