none
Help! Soap connection problems RRS feed

  • Question

  • I'm trying to create a new SOAP service connection data source using Designer 2010.

    I enter the service description URL, with "?wsdl" at the end, and it connects just fine, providing me with a Port and a list of Operation choices. However, no matter what Operation I choose, I only see a single Parameters entry, called "parameters", that, when I click the Modify button, allows me to enter a corresponding value that is "Element: 1 of 1". This is true whether I select an operation with no parameters, one parameter, or more than one parameter.

    Is this really what I should get? The Web Services layer I am connecting to is WebLogic. No name/password is required. I've tried various operation/parameter entries, but I always get an error ("The server returned a non-specific error...") when I try to add a Data View to a page.

    Any idea what might be going wrong?

    Thanks,

    John

    Tuesday, October 5, 2010 1:43 AM

All replies

  •  

    I'm still really stuck on this -- can folks connect up successfully to a a non-Microsoft Web service?

     

    Wednesday, October 6, 2010 3:19 PM
  •  

    My third attempt to get a response. Please help me! Is there anybody who's gotten Designer 2010 to successfully interact with non-Microsoft SOAP services??? Any ideas on how to avoid the problem above? This is a total show stopper.

    John

    Monday, November 29, 2010 5:56 AM
  • I don't have any to test with, sorry.  With SharePoint web services, which are just normal SOAP, they work fine.  I wouldn't expect any other SOAP web service to work differently unless it's built abnormally, but I can't confirm.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Monday, November 29, 2010 9:01 AM
  •  

    There is nothing unusual about it -- it's a WebLogic server, one of the most popular servers on the market. It's been in use for quite a while, and works well with all are other software.

    Sunday, December 5, 2010 8:37 PM
  • Any update on this. Same issue here. The data is complex type and it just pull up one parameter int eh List with tns:
    Thursday, February 3, 2011 6:12 PM