none
BizTalk Server 2009 configuration wizard error RRS feed

  • Question

  • Hi,

    I have a Biztalk EDI application running in my production server, which uses the party configuration to create the EDI files. This server\EDI process has been running  well for a long time, only failing when i tried to create a Batch within the party configuration.

    The error Isee in my BizTalk Server configuration wizard is :

    BizTalk EDI/AS2 functionalities have been removed from this BizTalk Group. Please go to custom configuration to unconfigure this feature.

    Also in the Microsoft BizTalk Server 2009 Configuration Wizard, under the BizTalk EDI/AS2 Runtime, all the check boxes for various EDI options where showing as unchecked and the above mentioned error is available at the left hand corner.

    Any idea on how these could have happened? Guess reconfiguring EDI properties is the only way to go forward.

    Thanks!


    Ram
    Friday, January 7, 2011 10:28 PM

All replies

  • Hi,

        Have you deleted any DB entries related to Biztalk configuraton from the data base. This is only problem I can think of.

     

    Thanks

    Gyan


    If this answers your question, please mark it as "Answered".
    Monday, January 10, 2011 3:27 AM
  • Hi,

    By DB enteries, do you mean any Tables or stored procedures getting deleted from the BizTalkMgmtDb? Is reconfiguring the BizTalk EDI and AS2 properties using the configuration wizard the only option to solve this issue ? Can this reconfiguring be done without affecting the existing job(An edi job that runs without any issue, without the need of Batching in my Party configuration)?

    Thanks!


    Ram
    Monday, January 10, 2011 2:32 PM
  • Are you by chance using Windows 64 bit? I had something similar where the 64 bit windows caused some problems. I reinstalled 32 bit and the problem went away. It seemed that no matter what I did, I could not get the configuration to work.
    Please Indicate "Mark as Answer" if this Post has Answered the Question
    Wednesday, January 12, 2011 6:31 PM
  • We had the 32 bit version running and finaly its working now. When we uncofigured, we did not unconfigure it correctly thats the issue. Then configured it again and it worked fine.

    Thanks!


    Ram
    Thursday, January 13, 2011 7:59 PM
  • Good to know that your issue is resolved. However, i think you need to make sure nobody unconfigures features on your Prod Server (that's what it is I think someone did). the process that was running will not get affected until you try to access the features again which in this case you did by trying to go to batching etc...

    Since the EDI part was in use even though it was un-configured, the configuration mmc does not remove the dll's and dependencies which gets loaded when BizTalk is running and hence the then and present current process was running for a long time (as per your original post). It only removed the DB part from BizTalk DB's/Tables

    By reconfiguring you simply put the EDI/AS2 feature set back from a DB standpoint and it works now.

     

    -amit


    amit kumar Please Indicate "Mark as Answer" if this Post has Answered the Question
    • Proposed as answer by technoamit Wednesday, January 19, 2011 5:00 PM
    Wednesday, January 19, 2011 5:00 PM