locked
Run report as specified user RRS feed

  • Question

  • Report gets data from cube, cube uses security model based on Dimensions data & mapped user from ActiveDirectory.

    It works fine but we need some exception. One of the reports have to run always as "admin" for all users.

    How can I specify special user name for  the report?

     

    Monday, June 22, 2009 6:16 AM

Answers

  • In the advanced properties for the Analysis Services data source for that report, try setting the EffectiveUserName property.  This should show up when you use the UserName MDX function in your conditional security role expression.
    Paul Turley [Hitachi Consulting] SQLServerBIBlog.com
    • Proposed as answer by Paul TurleyMVP Monday, June 22, 2009 8:18 AM
    • Marked as answer by Raymond-Lee Friday, July 3, 2009 8:24 AM
    Monday, June 22, 2009 8:17 AM
  • Hi,

     

    In addition to Paul, you can also specify the report use a certain user account to query data from the cube. Create the report base on a custom data source not a shared data source. In Report Manger, click the report, click properties, and then switch to datasource, select the option “Credentials stored securely in the report server ”, enter the admin account and then select the option “Use as Windows credentials when connecting to the data source ”

     

    Hope this helps.

    Raymond

    • Marked as answer by Raymond-Lee Friday, July 3, 2009 8:24 AM
    Tuesday, June 23, 2009 6:28 AM

All replies

  • In the advanced properties for the Analysis Services data source for that report, try setting the EffectiveUserName property.  This should show up when you use the UserName MDX function in your conditional security role expression.
    Paul Turley [Hitachi Consulting] SQLServerBIBlog.com
    • Proposed as answer by Paul TurleyMVP Monday, June 22, 2009 8:18 AM
    • Marked as answer by Raymond-Lee Friday, July 3, 2009 8:24 AM
    Monday, June 22, 2009 8:17 AM
  • Hi,

     

    In addition to Paul, you can also specify the report use a certain user account to query data from the cube. Create the report base on a custom data source not a shared data source. In Report Manger, click the report, click properties, and then switch to datasource, select the option “Credentials stored securely in the report server ”, enter the admin account and then select the option “Use as Windows credentials when connecting to the data source ”

     

    Hope this helps.

    Raymond

    • Marked as answer by Raymond-Lee Friday, July 3, 2009 8:24 AM
    Tuesday, June 23, 2009 6:28 AM
  • Hi

    we have the same requirements. One open point is:

    What should we set under the membership tab of our role.

    We tried the following:

    - Service account of web application (account is also defined as an administator of the analysis server) : did not work
    - Everyone : works but of course is not acceptable

    Can someone help me thanks a lot.
    Monday, October 12, 2009 11:12 AM