locked
WSP with only Site Scoped Feature fails to deploy because it has "Web Scoped Features" RRS feed

  • Question

  • I have a WSP package with 3 Features, all three of which are Site scoped.  However, if I attempt to Install these via PoweShell, I get a warning saying that they contain Web-scoped objects and so can't be installed.

    Does anyone know what cause this?

    Thanks!

    Thursday, August 25, 2011 8:39 PM

Answers

All replies

  • seems content specific error and not a common one!
    "T" | community.zevenseas.com/Blogs/Tanmay/default.aspx
    Thursday, August 25, 2011 9:33 PM
  • Are you installing those Features explicitely using the Install-SPFeature cmdlet or are you getting the error while installing/deploying the WSP? Additionally could you tell something more about what those Features contain?
    w: http://blog.mastykarz.nl | t: @waldekm | c: http://mavention.codeplex.com | c: http://mavention.nl
    Friday, August 26, 2011 5:28 AM
  • I'm using separate steps in a PowerShell script, one for Add-SPSolution, one for Install-SPSolution, with a console-written pause and Y/N to continue, etc.  It seems to choke on the Install-SPSolution part.  I've tried this using a Web App URL (http://sp1010) and a specific Site Collection URL (http://sp2010/sites/sitename) and get the same error both times.

    Oddly, I don't get any such errors when using VS and the WSP Deploy command.  Of course, when I export the final package for production release, I have to include PowerShell scripts, not VS - that's how it'll be deployed for real, etc.

    Friday, August 26, 2011 12:55 PM
  • What commands are you using exactly? Could you tell something more about what your Solution is containing and what kind of Features do you have?
    w: http://blog.mastykarz.nl | t: @waldekm | c: http://mavention.codeplex.com | c: http://mavention.nl
    Friday, August 26, 2011 5:00 PM
  • Working on some other things, get back to you this evening.  Yes, I can include the PowerShell scripts and basics of the Features in the WSP.
    Friday, August 26, 2011 6:06 PM
  • Hi,

    I think you could verify the web Scope="WebApplication" on your feature definition. And set the ActivateOnDefault to False in feature property, then use Enable-SPFeature to a specific web application after install the install-spsolution commands.

    http://www.dotnetmafia.com/blogs/dotnettipoftheday/archive/2011/01/04/activating-and-deactivating-features-with-powershell-in-sharepoint-2010.aspx

    Alternatively, you can try to add a dummy elements(e.g. a web part) in the wsp solution which is site scoped.

    If the problem still exits, please post some detail information like the powershell command you used to deploy the wsp file.

    Hope this can help.

    • Marked as answer by sdfsda Tuesday, September 6, 2011 6:43 PM
    Tuesday, August 30, 2011 3:43 AM
  • Sorry, I haven't forgotten this, just stuck on other things.  I should be back with an answer the next couple days!

    Thanks!

    Wednesday, August 31, 2011 7:54 PM