locked
Unable to determine which solution file to build

    Question

  • Hello -

    I am running into this error when trying to deploy from GitHub to Azure.  The solution file has more than one solution in it.  Is this a limitation and hence I need to deploy in a different manner or there a way this should be handled?

    Thanks.

    Sunday, May 03, 2015 4:02 AM

Answers

All replies

  • Please see this page for info on selecting the project to build.
    • Proposed as answer by David EbboOwner Sunday, May 03, 2015 8:56 PM
    • Marked as answer by Eb_OneCare Tuesday, May 05, 2015 12:27 AM
    Sunday, May 03, 2015 4:14 AM
    Owner
  • I created .deployment.ini file in the root of the repo with contents similar to this:

    first

    [config]
    project = Venture.Web

    and then

    [config]
    project = Venture.Web/Venture.Web.csproj

    In both cases it did not work and I still got the error in the subject line.  Am I specifying something incorrectly?

    Thanks.

    Sunday, May 03, 2015 10:52 AM
  • The file name should be .deployment, not .deployment.ini :)

    Note that you can also do it using App Settings if you refer, per that same article.

    Sunday, May 03, 2015 1:19 PM
    Owner
  • Got it.  I did get it to work with the App Settings.

    Thanks.

    Sunday, May 03, 2015 8:34 PM
  • Can you share what app settings value worked for you? I keep getting an error with the paths after trying a variety of paths...

    Tried:

    • SolutionName/ProjectName
    • RepositoryName/PathTo/File.csproj
    • PathTo/File.csproj

    And possibly some other attempts that I'm forgetting. Keep seeing :

    Could not find a part of the path 'D:\home\site\repository\ {whatever path value I tried}

    Wednesday, June 03, 2015 8:47 PM
  • Pointing to the csproj is the way to go (relative to the repo root). Is the path that it complains about the correct path that you expect for your csproj? If so, please check with Kudu Console whether the csproj file is indeed where you expect it to be.

    If it complains about not finding it there, chances are that it's not there.

    Wednesday, June 03, 2015 9:03 PM
    Owner
  • Thank you, console access definitely helped to make sure my paths were correct. It now works!
    Friday, June 05, 2015 5:00 PM