locked
Exporting images in Design is *never* acurate RRS feed

  • Question

  • So, I have been using Design for a pretty long time now... since the very first beta, and I *still* can't get an accurate export. Using the smooth vs crisp option was *supposed* to help but it's still the same old problem. Changes in my measurements upon exporting.

    Look, if i select an object in my design that is 20px by 20px, it should be a "20px by 20px" img. I don't care *what* format it's in ( jpg, png, tif). How do we fix this problem because, as a designer, it's a biggie. I've got loads of work to be sliced and exported for various web and mobile applications and I'm *thiiis* close to going back to Adobe... just for the accuracy.

    So help a girl out here. Please fix, or tell me how i can currently fix the problem... and if you say i have to actually slice every element with the element tool, I may scream... because why give me the ability to export a selected object that clearly says one dimension and not let me accurately export to the same dimension.

    Okay, rant done.

    Thanks-

    Karen

    p.s.- my fellow designers and I have been ranting about this one for awhile.... so i know that it's a "known" issue.

    Thursday, August 5, 2010 2:36 PM

All replies

  • I too have been working with Design for a while and have never had this problem.  Sounds like it must be some sort of setting wether application or OS.  I am sorry to hear this and wish I could help you sove it.  Thanks, Jayson
    Jayson
    Saturday, August 7, 2010 5:25 AM
  • Hmmm to be fair...

    The design suite has lots of exotics but no real coherence.

    A mishmash of bundled stuff but no clear workflow ethic and, I think, that is the essence of what the poster is elaborating?

    Saturday, August 7, 2010 9:12 PM
  • I don't use that often the slice tool so maybe you have already tried what I'm saying. Sometimes slices get rounded while exporting so the final result may be one pixel off. It is not a good thing, but while waiting some kind of fix, if you size your slice using the bottom bar, the W and H properties, you may avoid those roundings errors. So click your slice, uncheck the "link width and height slider" (the chain symbol or whatever is called) and manually type your measure in the W and H boxes.

    Note: you may want to export a 200x200 area into a 100x100 final image, in this case type 200x200 in the width and height in the bottom bar, and then in the slice properties specify the destination is 100x100.

    Tuesday, August 10, 2010 9:00 PM
  • Old thread but still unanswered,

       A fix for this is to change the rectangle antialiasing from crisp to smooth in the general options. Get there by following the following menus: Edit>Options>General.


    Thanks, Jayson
    • Proposed as answer by Jayson Furr Tuesday, May 10, 2011 10:39 AM
    Tuesday, May 10, 2011 10:39 AM