none
Should we ship .net 3.5 framework SP1 as well as .net 4.0 as a pre-requisite since 4.0 does not has assemblies of version 2.0 RRS feed

  • Question

  • Hello,

    Our app is built against target framework as 3.5. We ship .Net 3.5 SP1 as a pre-requisite with our setup, which in turn installs .net 2.0 as well on the client machine. We use third party components which might be referring 2.0 assemblies as specific version. Now, we are planning to migrate to .net 4.0 and VS 2010.

    Should we ship both .net 3.5 framework SP1 and  .net 4.0 as a pre-requisite since 4.0 does not has assemblies of version 2.0?
    Or is it ok if we only ship .ent 4.0? But in that case will those third party components which expect 2.0 assemblies work as expected?

     


    Thanks & Regards, Gulab.
    • Moved by YiChun Chen Wednesday, December 16, 2009 3:29 AM I am moving this thread to the ".NET Framework Setup" forum, since the issue is related to .NET Framework side by side (From:.NET Framework 4 setup & deployment (Pre-Release versions))
    Tuesday, December 15, 2009 1:38 PM

Answers

  • Hi Gulab,

    Thank you for your post.

    The compatibility goal for the .Net Framework is that applications and components from previous versions should work smoothly on the .Net Framework 4.0, except for a set of known changes. It's the target for .NET 4.0 RTM version.

    .NET Framework 4.0 is still not released. The latest one is Beta version. Thus, it would be hard to say whether your .NET 3.5 application can be run properly on .NET 4.0 machine. We had better not to apply beta product for commercial application. To make your application more stable, please deploy it with .NET Framework 3.5 SP1.

    However, for your interests, you might have a try. Here is a helpful thread that shed some light on .NET Framework Compatibility testing:
    http://social.msdn.microsoft.com/Forums/en/netfxappcompatprerelease/thread/d307e0af-10e7-4aca-9582-a60844857f73

    If you have any concern on .NET 4.0 Application Compatibility issue, you can post your concern on .NET Framework 4 Application Compatibility - Beta 2 forum to get more useful help there.

    To make your application more stable, it would be better to deploy it with .NET Framework 3.5.

    Hope this helps. If you have any concern, please feel free to let me know.

    Best regards,
    YiChun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by gulabt Wednesday, December 16, 2009 11:10 AM
    Wednesday, December 16, 2009 5:13 AM
  • Thanks for replying YiChun Chen. We installed .Net 4.0 on a clean VM, it only installs .Net 4.0 client profile and .Net 4.0 extended beta. So if your application refers System Dlls of version 2.0, your application might not work. thus, we'll need to ship both .Net 3.5 SP1 as well as .Net 4.0

    Thanks & Regards, Gulab.
    • Marked as answer by gulabt Monday, December 21, 2009 10:23 AM
    Monday, December 21, 2009 10:21 AM

All replies

  • Hi Gulab,

    Thank you for your post.

    The compatibility goal for the .Net Framework is that applications and components from previous versions should work smoothly on the .Net Framework 4.0, except for a set of known changes. It's the target for .NET 4.0 RTM version.

    .NET Framework 4.0 is still not released. The latest one is Beta version. Thus, it would be hard to say whether your .NET 3.5 application can be run properly on .NET 4.0 machine. We had better not to apply beta product for commercial application. To make your application more stable, please deploy it with .NET Framework 3.5 SP1.

    However, for your interests, you might have a try. Here is a helpful thread that shed some light on .NET Framework Compatibility testing:
    http://social.msdn.microsoft.com/Forums/en/netfxappcompatprerelease/thread/d307e0af-10e7-4aca-9582-a60844857f73

    If you have any concern on .NET 4.0 Application Compatibility issue, you can post your concern on .NET Framework 4 Application Compatibility - Beta 2 forum to get more useful help there.

    To make your application more stable, it would be better to deploy it with .NET Framework 3.5.

    Hope this helps. If you have any concern, please feel free to let me know.

    Best regards,
    YiChun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by gulabt Wednesday, December 16, 2009 11:10 AM
    Wednesday, December 16, 2009 5:13 AM
  • Thanks for replying YiChun Chen. We installed .Net 4.0 on a clean VM, it only installs .Net 4.0 client profile and .Net 4.0 extended beta. So if your application refers System Dlls of version 2.0, your application might not work. thus, we'll need to ship both .Net 3.5 SP1 as well as .Net 4.0

    Thanks & Regards, Gulab.
    • Marked as answer by gulabt Monday, December 21, 2009 10:23 AM
    Monday, December 21, 2009 10:21 AM
  • Hi Gulab,

    Thank you for your kindly sharing! I really appreciate that.

    Have a great week!

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Edited by YiChun Chen Tuesday, December 22, 2009 6:34 AM typo
    Tuesday, December 22, 2009 5:40 AM