locked
xamarin build error RRS feed

  • Question

  • User244067 posted

    I have open 2017 project from 2019. Now i am getting this error. my Xamarin.Android.Support.Core.Utils version is 27.0.2 and Xamarin.Android.Support.v4 is 23.4.0.1

    The type 'FileProvider' exists in both 'Xamarin.Android.Support.Core.Utils, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' and 'Xamarin.Android.Support.v4, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'

    Monday, January 13, 2020 9:14 AM

All replies

  • User382871 posted

    1.Close the VisualStudio, clean the content in bin and obj folder. Reopen the project and try again. 2.If above not work, try to update the packages to the lastest statable version.

    Now i am getting this error. Please post the details about the error.

    Monday, January 13, 2020 11:10 AM
  • User244067 posted

    @ Jarvan

    Now i am getting this error

    Monday, January 13, 2020 11:45 AM
  • User382871 posted

    Hi, does cleaning the clean the content in bin and obj folder not work?

    Monday, January 13, 2020 12:59 PM
  • User244067 posted

    @Jarvan said: Hi, does cleaning the clean the content in bin and obj folder not work?

    I did it. after that now i am getting this error.

    Tuesday, January 14, 2020 8:34 AM
  • User382871 posted

    warning: unable to build chain to self-signed root for signer This error occurs on Xcode. Try to unload the ios platform project and deploy the android platform project.

    Check the link: https://stackoverflow.com/questions/47307416/xcode-ios-app-development-code-signing

    Tuesday, January 14, 2020 11:23 AM
  • User362308 posted

    i cleared bins, i cleared certificates and recreated them, i removed my apple account from xcode and visual studio and re added them, this same message keeps appearing

    Thursday, April 23, 2020 1:42 PM
  • User394393 posted

    I am facing build issue in release mode

    Monday, April 12, 2021 5:42 AM
  • User366502 posted

    Hi, did you find a solution? I handed over the apple Worldwide Developer Relations (https://developer.apple.com/de/support/expiration/) certificates, but it still does not work

    Monday, April 12, 2021 4:55 PM
  • User368382 posted

    Have you downloaded the new Apple Intermediate Certificate and installed to your KeyChain? https://developer.apple.com/de/support/expiration/

    Tuesday, April 13, 2021 6:19 AM