none
Visual Studio enterprise 2015 with update 1 Offline Installation RRS feed

  • Question

  • Hi,

    I am trying to perform an offline installation of visual studio enterprise 2015 with update 1 on windows 10 enterprise 64-bit machine. For that I followed steps mentioned at (https://msdn.microsoft.com/en-us/library/e2h7fzkw.aspx#BKMK_Offline)  and downloaded web installer "vs_enterprise_ENU.exe" from  https://www.visualstudio.com/downloads/download-visual-studio-vs. I run that setup (using /layout switch) and when that setup finished it doesn't showed message "Setup Successful! All specified components have been acquired successfully". It showed following error :

    • VSSecondaryInstaller_box: Some package failed to download.

    However, it downloaded enormous 11.3 GB package. I ran the installation setup by choosing optional features including (SDK, emulators). After setup is finished all components are installed successfully except emulators. It showed message "Setup Completed! However, not all  features installed correctly". It showed following error :

    • Emulators for Windows 10 mobile (10.0.10586): The installer failed. There was a problem downloading your product. Error code: 15605

    Why it is downloading emulators during installation setup even I had downloaded all packages using /layout switch. I had tried downloading and installation two times and both times these same errors occurred. I want to try for one more time so before that please sort out my errors so that this time I can download and install vs 2015 correctly.

    Is it at all possible to install VS 2015 on a completely disconnected machine? If so, what are the prerequisites? Any help would be greatly appreciated.

    Tuesday, February 23, 2016 5:20 AM

Answers

  • @rajattiwari2710,

    Based on my understanding the /layout command from Visual Studio by default will help us download those default components. The optional shared components I'm not so sure whether it is download properly. What about focus on this error and use the exe from here with /layout command: https://go.microsoft.com/fwlink/?LinkId=698769

    I've tested it and layout command is support for this exe:

    To install the emulator I think you can use the above way to download the package.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, February 24, 2016 7:04 AM
    Moderator

All replies

  • @rajattiwari2710,

    Based on my understanding the /layout command from Visual Studio by default will help us download those default components. The optional shared components I'm not so sure whether it is download properly. What about focus on this error and use the exe from here with /layout command: https://go.microsoft.com/fwlink/?LinkId=698769

    I've tested it and layout command is support for this exe:

    To install the emulator I think you can use the above way to download the package.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, February 24, 2016 7:04 AM
    Moderator
  • Thanks a lot Barry Wang for your quick and helpful support. I followed your suggestion and my problem is totally solved
    Friday, February 26, 2016 2:55 AM