locked
HTTP ERROR 500 WordPress Azure App RRS feed

  • Question

  • Greetings for the day.

    My Azure WordPress site http://sibeeshpassion.com/ is giving me an HTTP ERROR 500. To resolve I had done the following the fixes already, unfortunately, none worked.

    1. Creating new httaccess to check whether it is corrupted Setting limit in Wp-Config
    2. Creating new php.ini file in Wp-admin with limit
    3. Now I need to disable the plugins and find out which plugin is causing this issue, as the site is down, I can not log in and do that. So the only option is FileZilla or FTP. But when I try changing the folder 'Plugins' I am getting access is denied message.

    Any solutions available? Your help is much appreciated. Thanks in advance.


    Sunday, August 27, 2017 4:55 PM

Answers

  • After stopping the App Service in the Azure portal, I was able to rename the folder name. To stop, please do the preceding steps.

    • Login to Azure Portal
    • Go to the App Service
    • Click on Stop as showing in the below image

    Once after renaming the plugin folder, my site was up and running. Then I uploaded the plugins one by one and found wp-super-cache plugin was causing the issue, hence deleting that fixed the issue permanently.


    Monday, August 28, 2017 4:39 PM

All replies

  • I would suggest you check the FREB log to see what model gives the 500 error.

    You may check the below link to enable diagnostic logging for web app
    https://docs.microsoft.com/en-us/azure/app-service-web/web-sites-enable-diagnostic-log
    -----------------------------------------------------------------------------------------------------------------
    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.


    • Proposed as answer by Nayana A S Monday, August 28, 2017 4:56 AM
    • Edited by Nayana A S Monday, August 28, 2017 9:53 AM
    Monday, August 28, 2017 4:56 AM
  • After stopping the App Service in the Azure portal, I was able to rename the folder name. To stop, please do the preceding steps.

    • Login to Azure Portal
    • Go to the App Service
    • Click on Stop as showing in the below image

    Once after renaming the plugin folder, my site was up and running. Then I uploaded the plugins one by one and found wp-super-cache plugin was causing the issue, hence deleting that fixed the issue permanently.


    Monday, August 28, 2017 4:39 PM
  • Glad to know your issue has been resolved. Much appreciated for sharing the solution as it may help other community members.
    -----------------------------------------------------------------------------------------------------------------
    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Wednesday, August 30, 2017 2:57 AM
  • Hi, to detect what is causing the generic HTTP 500 error, you need to enable the debug mode on Worpress:

    Open the file "wp-config.php" and make sure that define WP_DEBUG is true:

    define('WP_DEBUG', true);

    After That you will be able to figure out the kind of plugging or files are causing the issue.

    If you need to manually disable a plugging or theme, you only need to rename plugging/theme folder to "anyname"-disabled:


    • Proposed as answer by Samuel.diogo Tuesday, February 27, 2018 11:45 AM
    • Edited by Samuel.diogo Tuesday, February 27, 2018 11:47 AM
    Tuesday, February 27, 2018 11:44 AM
  • thanks alot mate. this works for me. been on this problem for days now
    Sunday, December 16, 2018 3:42 AM