none
BizTalk 2010 with Swift Accelerator: Upgrade to BizTalk 2013R2 RRS feed

  • Question

  • Hi,

    we plan to upgrade (in-place) our BizTalk 2010 server (with installed Swift Accelerator Pack). What is the preferred way of upgrading the Swift Accelerator? Do we have to install the new Swift Accelerator Pack for BizTalk 2013R2 after the upgrade has finished?

    Regards

    Roland

    Tuesday, September 6, 2016 3:12 PM

Answers

  • Hi,

    for some reasons a normal side-by-side upgrade is not possible.

    The applications will be migratet to VS2012 as well.

    Regards,

    Roland

    Hi Roland,

    Hold On!!

    If you are migrating to Biztalk 2013 R2, Visual Stuio 2012 wont work. You require VS 2013 for that.

    Refer the hardware and Software requirements for Biztalk 2013 and R2

    Even in this case the target framework of the solutions will be changed to 4.5.x after the migration. I would suggest going for the installation of the SWIFt accelerator pack shipped with the Biztalk 2013 R2 so that you dont face in unwanted issues.

    So the correct way would be,

    1) Get the Installation of Biztalk 2013 R2 complete

    2) Configure the Biztalk 2013 R2

    3) Install the SWIFT accelerator pack

    4) Upgrade the solutions in VS 2013 and then test the solutions.

    Regards,


    Mandar Dharmadhikari

    • Proposed as answer by Angie Xu Wednesday, September 21, 2016 6:06 AM
    • Marked as answer by Angie Xu Wednesday, September 21, 2016 6:06 AM
    Wednesday, September 14, 2016 10:37 AM
    Moderator

All replies

  • Apparently yes, Swift pack for BizTalk 2013R2 ships with the product. You would need to install them and not use 2010 packages.

    For the upgrade, is there any specific reason why you are doing an inplace upgrade ? Because for any changes to apps , artifacts etc the solution will have to be rebuilt with newer VS,.NET framework etc.

    Even though Inplace upgrade is available, normally a migration is suggested to be done side by side and microsoft also helps in licenses re use during migration phase. 


    Pi_xel_xar

    Blog: My Blog

    BizTalkApplicationDeploymentTool: BizTalk Application Deployment Tool

    LinkedIn: LinkedIn

    Tuesday, September 6, 2016 4:17 PM
    Answerer
  • Hi,

    for some reasons a normal side-by-side upgrade is not possible.

    The applications will be migratet to VS2012 as well.

    Regards,

    Roland

    Wednesday, September 14, 2016 9:56 AM
  • Hi,

    for some reasons a normal side-by-side upgrade is not possible.

    The applications will be migratet to VS2012 as well.

    Regards,

    Roland

    Hi Roland,

    Hold On!!

    If you are migrating to Biztalk 2013 R2, Visual Stuio 2012 wont work. You require VS 2013 for that.

    Refer the hardware and Software requirements for Biztalk 2013 and R2

    Even in this case the target framework of the solutions will be changed to 4.5.x after the migration. I would suggest going for the installation of the SWIFt accelerator pack shipped with the Biztalk 2013 R2 so that you dont face in unwanted issues.

    So the correct way would be,

    1) Get the Installation of Biztalk 2013 R2 complete

    2) Configure the Biztalk 2013 R2

    3) Install the SWIFT accelerator pack

    4) Upgrade the solutions in VS 2013 and then test the solutions.

    Regards,


    Mandar Dharmadhikari

    • Proposed as answer by Angie Xu Wednesday, September 21, 2016 6:06 AM
    • Marked as answer by Angie Xu Wednesday, September 21, 2016 6:06 AM
    Wednesday, September 14, 2016 10:37 AM
    Moderator
  • We do support in-placement upgrades from 2010 to 2013R2 (just keep in mind that we are launching BizTalk 2016 soon).

    I you are uncertain on how to do this contact Microsoft Premier Support, they can assign a PFE to help assist during the in-placement upgrade.

    // Tord

    Wednesday, September 14, 2016 6:49 PM
  • Hello Tord,

    thank you for the reply.

    Currently our BizTalks are BizTalk 2010 with HIS and Swift Accelerator 2010.

    What is the recommended way to do an inplace upgrade?

    Currently 2016 is not an option because it requires Win2012 which is not on our roadmap currently.

    Kind regards

    Roland


    Friday, September 23, 2016 10:04 AM
  • The Swift Accelerator is not a part of the BizTalk package, it is a seperate installer.
    Friday, September 30, 2016 8:00 AM