locked
SQL Server 2008 R2 Migration to SQL Server 2012 Pre - Login Handshake error. RRS feed

  • Question

  • I have 2 SQL Servers, the details are as at the below. The New SQL Server is using to host the databases of the old SQL Database server.
     
    OLD SQL Server
     
    Windows Server 2008 R2
    SQL Server 2008 R2
    AD DS Installed & Added to a Domain named 'TheKingsburycmb.com'
    IP Static - 192.168.1.180
    Default Gateway - 192.168.1.1
    Prefered DNS - 192.168.1.180
    Alternate DNS - 203.115.0.46
     
    I want this server's database's data to be transferred to the new SQL Server.
     

    New SQL Server
     
    Windows Server 2012 Standard
    SQL Server 2012 Standard
    AD DS Installed & promote to the previous domain 'TheKingsburycmb.com'
    IP Static - 192.168.1.181
    Default Gateway - 192.168.1.1
    Prefered DNS - 192.168.1.180
    Alternate DNS - 203.115.0.46
     
    I want this server acts as the new SQL Server with old databases of the old server.
     
    So what I have done is I connected to the New SQL Server to the its SQL Management Studios'
    object explorer and it was a success but when I tried to add the OLD SQL Server to the New
    SQL servers' Management Studio I got an error saying that as at the below!

    ---------------------------------------------------------------------------------------------
    Cannot connect to OLDSQLServerName.
     
    ------------------------------
    ADDITIONAL INFORMATION:
     
    Connection Timeout Expired. The timeout period elapsed while attempting to consume the
    pre-login handshake acknowledgement. This could be because the pre-login handshake failed
    or the server was unable to respond back in time. The duration spent while attempting to
    connect to this server was - [Pre-Login] initialization=22100; handshake=0; (Microsoft SQL
    Server, Error: -2)
     
    ---------------------------------------------------------------------------------------------
     
    I have enabled Named Pipes of both SQL Server Configuration Managers. But I cannot understand what is the problem that is keeping restricting the adding the OLD SQL Server to the New SQL Servers Management Studio using Object Explorer?
     
    Could you someone help me to solve this matter?
     
    Thanks,
    Regards,
    Chiranthaka
    Monday, February 24, 2014 2:56 AM

Answers

  • Hello,

    Could you try to disable or configure Windows Firewall on the new server to allow SQL Server access?

    http://technet.microsoft.com/en-us/library/ms175043(v=sql.110).aspx

    Disable any security software.

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    • Proposed as answer by Sofiya Li Tuesday, February 25, 2014 9:32 AM
    • Marked as answer by Sofiya Li Tuesday, March 4, 2014 9:24 AM
    Monday, February 24, 2014 4:57 AM
  • Check firewall settings and make sure the port is not blocked and browser services are running.

    Please click the Mark as answer button and vote as helpful if this reply solves your problem

    • Proposed as answer by Sofiya Li Tuesday, February 25, 2014 9:32 AM
    • Marked as answer by Sofiya Li Tuesday, March 4, 2014 9:24 AM
    Monday, February 24, 2014 5:56 AM

All replies

  • Hello,

    Could you try to disable or configure Windows Firewall on the new server to allow SQL Server access?

    http://technet.microsoft.com/en-us/library/ms175043(v=sql.110).aspx

    Disable any security software.

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    • Proposed as answer by Sofiya Li Tuesday, February 25, 2014 9:32 AM
    • Marked as answer by Sofiya Li Tuesday, March 4, 2014 9:24 AM
    Monday, February 24, 2014 4:57 AM
  • Check firewall settings and make sure the port is not blocked and browser services are running.

    Please click the Mark as answer button and vote as helpful if this reply solves your problem

    • Proposed as answer by Sofiya Li Tuesday, February 25, 2014 9:32 AM
    • Marked as answer by Sofiya Li Tuesday, March 4, 2014 9:24 AM
    Monday, February 24, 2014 5:56 AM