The following forum(s) have migrated to Microsoft Q&A (Preview): Azure App Service - Web Apps!
Visit Microsoft Q&A (Preview) to post new questions.

Learn More

 locked
Publisher Domain - unexpected content type header RRS feed

  • Question

  • I set up an app for OAuth and am trying to verify my domain via the "Configure a Domain" mechanism. I have uploaded the JSON file to the requested URL, but no matter what I do I get the error message:

    Verification of publisher domain failed. Error getting JSON file from https://www.bscotch.net/.well-known/microsoft-identity-association. The server returned an unexpected content type header value. []

    Things I have tried:

    • Allowing the URL to work with and without the ".json" extension, since the error message does not show the extension but the instructions do.
    • Sending from the browser and from Postman.
    • My server was returning "application/json; charset=UTF-8" as the content-type. I made it instead randomly choose a different content-type on every request, in hopes that one of them would work. The ones I Tried included:

      "text/plain",
      'application/json; charset=UTF-8',
      'text/javascript',
      'text/x-json'

    What am I missing here? It seems like this should have been a trivial process.

    Thursday, August 8, 2019 6:38 PM

All replies

  • Hi 

    Thanks for raising the issue.

    We are investigating and will update you shortly

    Friday, August 9, 2019 2:25 PM
    Moderator
  • Could you please send an email to AzCommunity[at]Microsoft[dot]com referencing this thread, we would like to work closer with you on this matter
    Monday, August 19, 2019 4:29 AM
    Moderator