locked
Workflow Designer became Very Slow on my laptop RRS feed

  • Question

  • Hi, In my application I''m hosting the Workflow designer (WF 3.5 - yes I know this is obsolete but I can't move to 4 shortly, so I have to keep using the old one). Lately the hosted workflow designer became veeeeery slow in opening the workflow. It was never been a flash but it was reasonably quick. I don't know what happened but now it takes 10 times more to open. On the desktop PC it works fine. Does somebody knows what could be the reason?

    I have a HP PAvilion dv7 (i7-2670QM 8GB RAM Samsung SSD 830 256GB) running Windows 8 Pro 64bit.

    Thanks Alessandro

     
    Monday, May 6, 2013 8:38 AM

Answers

All replies

  • Hi,

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Regards,


    Chen Yu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, May 7, 2013 10:18 AM
  • The most commonly reported issues are:

    1. Time taken to open a workflow document is long.
    2. Opening Activity bind dialog is slow.

    These are addressed with hotfixes in KB 980951 and KB 980952. Please contact Microsoft Support to obtain these.

    Please see the blog http://blogs.msdn.com/b/madhuponduru/archive/2008/09/30/workflow-designer-and-performance.aspx for tips to make the designer perform better.

    Amy McElhaney
    Microsoft Developer Support, DSI Distributed Services

    • Marked as answer by Molly Chen_ Tuesday, May 21, 2013 3:33 AM
    Friday, May 10, 2013 8:40 PM
  • Thanks for your reply! Opening it takes a long time even on empty workflows, but most strange thing is that on my old laptop (HP Pavilion d9770 - Intel T8100 4GB RAM Windows 7 64bit) it works perfectly, only on my new laptop (HP Pavilion dv7-6B41EL - i72670QM 8GB RAM Windows 8 Pro 64bit) it is very slow loading the designer even if empty.  I'll try to get the hotfixes if can help.

    Best regards

    Alessandro

    Monday, May 13, 2013 8:53 PM