locked
SSRS 2008 R2 strange Authentication Issues RRS feed

  • Question

  • Anonymous access issues in 2K8 R2.
    • Edited by Chandan jha Tuesday, June 19, 2012 12:14 PM
    Thursday, May 17, 2012 11:17 AM

Answers

All replies

  • Hi,

    check whether sandy have the Browser rights on the parent folder of report manager.

    regards,


    Noman Rao


    • Edited by Noman Rao Thursday, May 17, 2012 11:50 AM
    Thursday, May 17, 2012 11:50 AM
  • Hi,

    check whether sandy have the Browser rights on the parent folder of report manager.

    regards,


    Noman Rao


    I already mentioned that the users do not have to have browser permissions. We have a basic authentication setup on the internet webpage and it should use one common account to reach the SSRS report because it has got browser permissions. We cannot give all the individual users browser permissions. In that case what will happen to non-domain users?

    Think it like this, when I open my bank statement report, there will be an authentication set for me. I just put my id and password. I need not have the browser permissions to bank server or read permissions on databases.

    Thanks

    Chandan

    Thursday, May 17, 2012 12:39 PM
  • Does anybody has any solution to this?

    Thanks

    Chandan

    Friday, May 18, 2012 6:50 AM
  • Hi Chandan,

    Sorry for the delay.

    From your description, does the issue occur when opening the new report or opening all the reports on the report server? If the issue occurs when viewing any report on the report server, the issue might be the Basic Authentication related. To configure the Basic Authentication in Reporting Services, please see:
    How to: Configure Basic Authentication in Reporting Services

    If the issue occurs only when accessing the new report, I suggest that you check the data source properties of the report. If the report uses a custom data source, please configure the stored credentials by using the “domain\ssrs_virtual” account.

    Hope this helps.

    Regards,
    Mike Yin

    TechNet Subscriber Support
    If you are
    TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Monday, May 21, 2012 8:25 AM
  • Hi Chandan,

    Sorry for the delay.

    From your description, does the issue occur when opening the new report or opening all the reports on the report server? If the issue occurs when viewing any report on the report server, the issue might be the Basic Authentication related. To configure the Basic Authentication in Reporting Services, please see:
    How to: Configure Basic Authentication in Reporting Services

    If the issue occurs only when accessing the new report, I suggest that you check the data source properties of the report. If the report uses a custom data source, please configure the stored credentials by using the “domain\ssrs_virtual” account.

    Hope this helps.

    Regards,
    Mike Yin

    TechNet Subscriber Support
    If you are
    TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Thanks for your reply. The connection from the report internally is going to the databases as domain\ssrs_virtual only. The problem comes when a user tries to browse the report. We have custom build security so any non-domain guys should able to access the report if they suppy correct username and password. However, the SSRs expects them to have browser rights. since these guys come under 'anonymous' category, we need to build anonymous access for SSRS reports but this is not supported in 2008R2 because IIS is no longer used by SSRS.

    So in short, we need to have anonymous access to these reports but we are not able to find help. Web forums do give some tips but nobody is damn sure if that helps.

    Kindly help me.

    Thanks

    Chandan

    Tuesday, May 22, 2012 8:19 AM
  • Hi Chandan,

    Thanks for your posting.

    In SQL Server 2008 R2, the Anonymous access to report server cannot be enabled unless we use a custom authentication. Now that you use the Basic Authentication, you can refer to the Microsoft’s suggestion in the following link:
    https://connect.microsoft.com/SQLServer/feedback/details/565010/anonymous-access-with-ssrs-2008-r2-not-working

    If you are interested in the custom authentication, please see:

    For the detailed information to enable Anonymous access in SQL Server 2008 R2 Reporting Services with custom authentication, please see the blogs below:

    Regards,
    Mike Yin

    • Marked as answer by Chandan jha Thursday, May 24, 2012 10:47 AM
    Wednesday, May 23, 2012 4:12 AM
  • Hi Chandan,

    Please refer User Account Control (UAC) and SSRS


    Thanks,
    Sandip Shinde


    Please remember to mark the replies as answers if they help you and unmark them if they provide no help.

    Wednesday, May 23, 2012 3:45 PM
  • Hi Chandan,

    Thanks for your posting.

    In SQL Server 2008 R2, the Anonymous access to report server cannot be enabled unless we use a custom authentication. Now that you use the Basic Authentication, you can refer to the Microsoft’s suggestion in the following link:
    https://connect.microsoft.com/SQLServer/feedback/details/565010/anonymous-access-with-ssrs-2008-r2-not-working

    If you are interested in the custom authentication, please see:

    For the detailed information to enable Anonymous access in SQL Server 2008 R2 Reporting Services with custom authentication, please see the blogs below:

    Regards,
    Mike Yin

    I will accept this as an answer and I believe it is out of a DBA's scope(in my case:-)) to deploy dll files. I will forward this solution to the dev team and hope they come out with flying colors.

    Thanks for help.

    Chandan

    Thursday, May 24, 2012 10:47 AM
  • Hi Chandan,

    Please refer User Account Control (UAC) and SSRS


    Thanks,
    Sandip Shinde


    Please remember to mark the replies as answers if they help you and unmark them if they provide no help.

    Thanks for the answer but this is not the issue here.

    Chandan

    Thursday, May 24, 2012 10:48 AM