none
WHCK Driver Memory Test Fails. Warning in the logs RRS feed

  • Question

  • I am running "Driver Memory Test" for my NIC drivers and the test pass on my dev set-up, but on the other setup it fails for the sub-test " Microsoft.WindowsLogoKits.DevFund.MemoryTest.DriverFootprint"and "Microsoft.WindowsLogoKits.DevFund.MemoryTest.NXPool"

    The third sub-test "Microsoft.WindowsLogoKits.DevFund.MemoryTest.MDLTest" passes on applying filters.

    The warning i see in the logs is

    " Xperf pool action returns error code

    -2147023504

    xxx events lost in this trace. Data will be unreliable.

    This is usually caused by insufficient disk bandwidth for ETW logging.
    Please try increasing the minimum and maximum number of buffers and/or
    the buffer size.  Doubling these values would be a good first attempt.
    Please note, though, that this action increases the amount of memory
    reserved for ETW buffers, increasing memory pressure on your scenario.
    See "xperf -help start" for the associated command line options.

    "

    Any ideas on what is happening here?


    • Moved by HLK ModeratorModerator Wednesday, October 3, 2012 6:30 PM WLK/WHCK related (From:Windows Hardware WDK and Driver Development)
    Wednesday, August 22, 2012 10:01 AM

Answers

  • Tried the test again with HCK version 8.59.29692(was using version 8.59.25584 before). The Test failed.

    But the test passed on reducing the RAM on my Blade server from 80 GB to 16 GB. Hope this will help someone else as well.

    Thursday, August 23, 2012 7:20 AM

All replies

  • Tried the test again with HCK version 8.59.29692(was using version 8.59.25584 before). The Test failed.

    But the test passed on reducing the RAM on my Blade server from 80 GB to 16 GB. Hope this will help someone else as well.

    Thursday, August 23, 2012 7:20 AM
  • Hello,

    I am trying to setup WHCK test setup and see that "Driver Memory Test" fails on any device on my setup with exact same error as posted here.

    HCK Controller is 8.59.29723 (so all latest QFE's are covered and also has the latest filter). HW wise its just adequate machine with Intel Xeon 3.4GHz (2 core) with 2GB RAM.

    Win 8 Client is AMD Athlon (2 Core) 1.2 GHz with 4 GB RAM.

    So reducing the RAM doesnt apply to my setup. Any ideas on what is going on here?

    Thanks,

    Bala

    Wednesday, October 17, 2012 4:23 PM
  • Hi Bala,

    The solution that we reached above was by trial and error. Thats not documented by MS anywhere. that said. First thing i noticed is the processor speed of your client. that should be minimum 2.0 GHz, i would also recommend having atleast 8 GB ram as the memory. If you can, please try to upgrade these. Hope this helps.

    For your reference (http://msdn.microsoft.com/en-us/library/windows/hardware/jj124068.aspx)

    Wednesday, October 17, 2012 6:38 PM
  • hi,

    I am same question, however, test failed after increase my RAM to 16G. the log is 

    " Xperf pool action returns error code

    -2147023504

    Some events lost in this trace. Data will be unreliable.

    This is usually caused by insufficient disk bandwidth for ETW logging. 
    Please try increasing the amount of installed RAW to resolve this error 

    "

    Wednesday, September 7, 2016 9:52 AM