Service Template deployment with configuration parameters using Windows Azure Pack RRS feed

  • Question

  • I currently have a development instance configured for Windows Azure Pack with Service Provider Foundation.  

    Using the featured WAPWrapper implementation, I have created my own method under the VMMOperation class (similar to the CreateVm method) to create a new Service with this technet article as a loose reference to creating a new Service without using Service Management Automation Runbooks.

    Relevant images listed below:

    As it is written, my code successfully instantiates a new configuration deployment using the specified Service Template parameter, however I cannot add a new service with TierConfigurations and (subsequently my VMConfiguration collection instantiated) so instead I have this result in VMM instead of a deployment with VMMConfiguration to specify the VM properties.

    If I try to add the TierConfigurations I am met with the following error:

    I find this strange, because "MyTestTierConfiguration" is the name of a ServiceTierAndVMConfiguration object but a ComputerTier object is something completely different in the SPFVMM service.

    My line of thought was that I would need to add a reference to a ComputerTier collection as the Service seems to accommodate this property (as seen above), but by pursuing this I am sent into a seemingly neverending sequence of hidden requirements where each property necessary for a new Service object (or child property) requires another reference further down the chain.

    Is it possible to simply add custom settings for a Service deployment object through the SPFVMM service in this manner? I wanted to follow the same code implementation the WAPWrapper sample  uses to create a VM from a VMTemplate but customizing parameters in this manner does not seem to be cooperative.

    Let me know if I need to supply any further code examples for clarification.

    Relevant Articles listed above:


    Technet Article:

    Wednesday, March 22, 2017 4:27 PM