none
Is there any other provider than DotConnect for using Postgres with EF Code First? RRS feed

  • Question

  • Hi there,

    I am trying to find a solution for my problem as described in the subject of this topic.

    It doesn't matter what search engine I use - at least I get the same answer: to use Postgres with Entity Framework I have to use either NpgSQL oder DotConnect.

    Well - NpgSQL does not support Code First - or I am just too stupid to get it running.

    And DotConnect is not free - only the professional version supports Code First - and I am not rich :)

    So - has  anybody here some ideas what to do now :) ?

    Thx

    DerFrix

    Monday, May 7, 2012 1:56 PM

Answers

  • Hi DerFrix;

    Microsoft has a Entity Framework provider page located [here].

    In order to support Code First the provider needs to support .Net Framework 4. Looking at PgnSQL they support up to .Net 3.5 so it will not support Code First. By the looks of it only DotConnect will give you support for Code First.

     


    Fernando (MCSD)

    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".

    Monday, May 7, 2012 9:13 PM