none
How to disable screen saver in registry of WinCE 6.0 R3 Device? RRS feed

  • Question

  • Hi,

    I am developing an OS image for my WinCE6.0 device.  I would like to disable the screen saver.  Please give me tips on how to do this.

    Thanks,

    Luan


    Luan Le
    Wednesday, March 2, 2011 5:26 PM

Answers

  • The device is going on suspend mode. This is not related to screen saver.

     

    To solve this you need to stop the device entering into suspend mode.

     

    In the platform.reg file edit the following as:

    [-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\Timeouts]
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\Timeouts]

     "ACSuspend"=dword:99999                 ; in seconds

    "ACSystemIdle"=dword:99999    ; in seconds

     

    ---Misbah


    Senior Design Engineer T.E.S Electronic Solutions (Bangalore-India) www.tesbv.com email-misbah.khan@tesbv.com
    • Marked as answer by LuanLe Thursday, March 3, 2011 7:34 PM
    Thursday, March 3, 2011 6:44 AM

All replies

  • Try setting the below registry key to zero:

    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Power]
      "ScreenPowerOff"=dword:0
    

    Tom Gensel PTG Systems, LLC
    http://www.ptgsystems.com
    Wednesday, March 2, 2011 5:45 PM
  • Hi Tom,

    I tried it out and my screen stills go black after some timeout duration.  I used Remote Registry Editor and confirmed that the registry is set as you suggested above.

    Thanks,

    Luan


    Luan Le
    Wednesday, March 2, 2011 9:42 PM
  • That's probably not a screen saver, but rather some power managment feature.  It could be the display and/or backlight being powered off, or perhaps device is entering suspend.  Use your remote registry editor to look for values in [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\Timeouts] and determine what timeout corresponds to what you are seeing.  If you change any of these values and you want them to take effect without a reboot you need to set the system-wide named event "PowerManager/ReloadActivityTimeouts".  See this link for more info on Power Manager timeouts - http://msdn.microsoft.com/en-us/library/ee497736.aspx


    Tom Gensel PTG Systems, LLC
    http://www.ptgsystems.com
    Wednesday, March 2, 2011 10:19 PM
  • How do you set the registry? In platform.reg or alter the registry after booted?
    Also the black screen might be caused by the display driver that entering a lower power state after user/system idle timeout.
    And you may try another way to set up screen off setting, using SystemParametersInfo with SPI_SETSCREENSAVETIMEOUT, uiParam = 0 and fWinIni = SPIF_UPDATEINIFILE. For more detail refer to http://msdn.microsoft.com/en-us/library/ee499131.aspx

    Wednesday, March 2, 2011 10:24 PM
  • Hi,

     

    Go through the blog..  there may be issue with reloading timeouts value. 

    http://www.e-consystems.com/blog/workaround-to-reload-the-power-manager-activity-timeout-upon-every-booting-in-hive-based-registry/

    -Anant


    Anant
    Thursday, March 3, 2011 4:40 AM
  • The device is going on suspend mode. This is not related to screen saver.

     

    To solve this you need to stop the device entering into suspend mode.

     

    In the platform.reg file edit the following as:

    [-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\Timeouts]
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\Timeouts]

     "ACSuspend"=dword:99999                 ; in seconds

    "ACSystemIdle"=dword:99999    ; in seconds

     

    ---Misbah


    Senior Design Engineer T.E.S Electronic Solutions (Bangalore-India) www.tesbv.com email-misbah.khan@tesbv.com
    • Marked as answer by LuanLe Thursday, March 3, 2011 7:34 PM
    Thursday, March 3, 2011 6:44 AM