none
2006 R2 custom adapter and SAP adapter upgrade RRS feed

  • Question

  • We are planning to upgrade to BizTalk Server 2010 Enterprise from 2006 R2. Can someone provide answers to the following two questions:

    1) A custom adpter was created using VS 2005 (framework 2.0) when we had 2006, and is currently being used in BizTalk 2006 R2.  Will the custom adapter be available in 2010 after the upgrade? Or must it be recompiled in a newer version of VS and reinstalled?

    2) The Upgrading to BizTalk Server 2010 from BizTalk Server 2009 or 2006 R2.docx document makes this statement on page 19:

    "The upgrade process only upgrades features that were part of your previous version of BizTalk Server. Because of this, new features such as the EDI/AS2/Project Build and WCF adapters are not installed during an upgrade. To install these features, rerun Setup after the upgrade, choose Modify, and select the features you want to install..."

    We have the WCF Adapters installed on our 2006R2 platform, they are used to communicate with SAP. If I am reading the above statement correctly, the WCF Adapters must still be installed after the 2010 upgrade is complete. Is that true?  And if so why - if the feature already exists in 2006R2.

    Many thanks - Hedge

    Thursday, February 23, 2012 3:31 PM

Answers

  • Hi Hedge,

    In general for existing adapters you can use the Migration Tool.

    For you custom adapter you have to recompile(build) with newer .NET version and WCF LOB SDK.

    I assume the adapters will be there, however it may be possible you have to rerun the setup as indicated by documentation. It is probably behaviour by design. I can not find/think of another explanation.

    HTH

    Steef-Jan Wiggers

    MVP & MCTS BizTalk Server 2010

    http://soa-thoughts.blogspot.com/ | @SteefJan

    If this answers your question please mark it accordingly


    BizTalk

    • Marked as answer by THedge11 Thursday, February 23, 2012 4:31 PM
    Thursday, February 23, 2012 3:55 PM
    Moderator

All replies

  • Hi Hedge,

    In general for existing adapters you can use the Migration Tool.

    For you custom adapter you have to recompile(build) with newer .NET version and WCF LOB SDK.

    I assume the adapters will be there, however it may be possible you have to rerun the setup as indicated by documentation. It is probably behaviour by design. I can not find/think of another explanation.

    HTH

    Steef-Jan Wiggers

    MVP & MCTS BizTalk Server 2010

    http://soa-thoughts.blogspot.com/ | @SteefJan

    If this answers your question please mark it accordingly


    BizTalk

    • Marked as answer by THedge11 Thursday, February 23, 2012 4:31 PM
    Thursday, February 23, 2012 3:55 PM
    Moderator
  • Thank you Steef....
    Thursday, February 23, 2012 4:32 PM