none
Problem to install .Net framework 4.5.1 after installed .Net framework 4.6. RRS feed

  • Question

  • I installed first .Net framework 4.6. to be able use VStudio 2013.
    But I found that I need to install also .Net framework 4.5.1 to be able use an old TOAD DATA POINT Pro 3.6.0.3276 version.


    Does Vstudio2013  will still working if I uninstall .Net framework 4.6. to be able to install  .Net framework 4.5.1  and then install back  .Net framework 4.6. ?

    thanks in advance for the advice. 

     

    CRISTINA~ MICROSOFT Forum


    • Edited by perezco Thursday, October 29, 2015 1:03 PM adding TOAD data point version
    Thursday, October 29, 2015 12:47 PM

All replies

  • Both versions you mention (4.5.1 and 4.6) are updates to .NET 4.0. AFAIK, if you have .NET 4.6 correctly installed, you also have 4.5.1.

    To check, use this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET 4.6 selected, then check the first ~20 lines of the tool log for the list of installed .NET versions. You should find both 4.6 and 4.5.1. Then, check the last few lines of the log for the test app result. If the return code = 0, your .NET 4.6 is correctly installed. Run the tool again with 4.5.1 selected, then recheck the test app return code.

    You also can check in Visual Studio. Create a simple project (e.g. C# Winform). Look at the project properties and check the drop down list of available .NET versions you can target. If both 4.5.1 and 4.6 are in the list, that's another indicator that both versions are installed.

    If, as I suspect, you find that you have both 4.5.1 and 4.6, you'll need to contact TOAD support for assistance.

    Please report your results here, so we can help if you do have a .NET issue. If you do need further help with .NET, please tell us your Windows version. Specific fixes will be different depending on your Windows version.


    • Edited by pvdg42 Thursday, October 29, 2015 2:37 PM
    Thursday, October 29, 2015 2:34 PM
  • Thanks Pvdg42,

     

    I  reinstall the Offline Installer Microsoft .NET Framework 4.6 ... no luck

    https://www.microsoft.com/en-us/download/details.aspx?id=48137

    The issue is the .net 4.6 does not allow to install .net 4.5.1 or .net 4.5.{old individual versions}

    Making TOAD data point failed in the installation.

    background
    OS Version Information: 
    OS Version = 6.1.7601, SP = 1.0, Platform 2, Service Pack 1
    OS Description = Windows 7 - x64 Enterprise Edition Service Pack 1

    Microsoft SQL Server 2014  
    Visual studio 2013 ultimate with update 4

    --------------------------------

    relate to what type .Net framework use TOAD DATA POINT is  .net 4.0 and 4.5
    for the  toad Dp  versions:
    3.6
    http://documents.software.dell.com/toad-data-point/3.6/installation-guide/installation/system-requirements
    3.61
    http://documents.software.dell.com/toad-data-point/3.6.1/installation-guide/installation/system-requirements
    3.7
    http://documents.software.dell.com/toad-data-point/3.7/installation-guide/installation/system-requirements
    3.8 beta
    http://dev.toadfordataanalyst.com/releasenotes/beta/ToadforDataAnalystsRNBeta.htm#SystemRequirements
    ---------------><><><><><---------------><><><><><---------------><><><><><---------------
    ---------------><><><><><---------------><><><><><---------------><><><><><---------------

    Log demostrate since .net 4 client ,4 Full, 4.5, 4.5.1, 4.5.2 until 4.6 with the result  

    4.5.1
    [10/29/15,10:24:11] Section [Registry - .NET Framework 4.5 (Wow6432Node)] - stop parsing entries
    [10/29/15,10:24:11] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [10/29/15,10:24:11] ExecutablePath = 'Netfx40TestApplication.exe'
    [10/29/15,10:24:11] FriendlyName = '.NET Framework 4 test application'
    [10/29/15,10:24:11] TimeoutSeconds = '300'
    [10/29/15,10:24:11] WaitOnExit = 'true'
    [10/29/15,10:24:11] Silent = 'true'
    [10/29/15,10:24:11] Launching process 'Netfx40TestApplication.exe' now
    [10/29/15,10:24:11] Process successfully launched. Waiting 300 seconds for it to complete.
    [10/29/15,10:24:11] Process 'Netfx40TestApplication.exe' exited with return code 0
    [10/29/15,10:24:11] Verification succeeded for product .NET Framework 4.5.1

    4.5.2
    [10/29/15,10:26:53] Section [Registry - .NET Framework 4.5 (Wow6432Node)] - stop parsing entries
    [10/29/15,10:26:53] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [10/29/15,10:26:53] ExecutablePath = 'Netfx40TestApplication.exe'
    [10/29/15,10:26:53] FriendlyName = '.NET Framework 4 test application'
    [10/29/15,10:26:53] TimeoutSeconds = '300'
    [10/29/15,10:26:53] WaitOnExit = 'true'
    [10/29/15,10:26:53] Silent = 'true'
    [10/29/15,10:26:53] Launching process 'Netfx40TestApplication.exe' now
    [10/29/15,10:26:53] Process successfully launched. Waiting 300 seconds for it to complete.
    [10/29/15,10:26:53] Process 'Netfx40TestApplication.exe' exited with return code 0
    [10/29/15,10:26:53] Verification succeeded for product .NET Framework 4.5.2

    4.6
    [10/29/15,10:27:37] Section [Registry - .NET Framework 4.5 (Wow6432Node)] - stop parsing entries
    [10/29/15,10:27:37] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [10/29/15,10:27:37] ExecutablePath = 'Netfx40TestApplication.exe'
    [10/29/15,10:27:37] FriendlyName = '.NET Framework 4 test application'
    [10/29/15,10:27:37] TimeoutSeconds = '300'
    [10/29/15,10:27:37] WaitOnExit = 'true'
    [10/29/15,10:27:37] Silent = 'true'
    [10/29/15,10:27:37] Launching process 'Netfx40TestApplication.exe' now
    [10/29/15,10:27:37] Process successfully launched. Waiting 300 seconds for it to complete.
    [10/29/15,10:27:37] Process 'Netfx40TestApplication.exe' exited with return code 0
    [10/29/15,10:27:37] Verification succeeded for product .NET Framework 4.6

    4.5
    [10/29/15,10:28:17] Section [Registry - .NET Framework 4.5 (Wow6432Node)] - stop parsing entries
    [10/29/15,10:28:17] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [10/29/15,10:28:17] ExecutablePath = 'Netfx40TestApplication.exe'
    [10/29/15,10:28:17] FriendlyName = '.NET Framework 4 test application'
    [10/29/15,10:28:17] TimeoutSeconds = '300'
    [10/29/15,10:28:17] WaitOnExit = 'true'
    [10/29/15,10:28:17] Silent = 'true'
    [10/29/15,10:28:17] Launching process 'Netfx40TestApplication.exe' now
    [10/29/15,10:28:17] Process successfully launched. Waiting 300 seconds for it to complete.
    [10/29/15,10:28:17] Process 'Netfx40TestApplication.exe' exited with return code 0
    [10/29/15,10:28:17] Verification succeeded for product .NET Framework 4.5

    4 Full
    [10/29/15,10:29:14] Section [Registry - .NET Framework 4 Full (Wow6432Node)] - stop parsing entries
    [10/29/15,10:29:14] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [10/29/15,10:29:14] ExecutablePath = 'Netfx40TestApplication.exe'
    [10/29/15,10:29:14] FriendlyName = '.NET Framework 4 test application'
    [10/29/15,10:29:14] TimeoutSeconds = '300'
    [10/29/15,10:29:14] WaitOnExit = 'true'
    [10/29/15,10:29:14] Silent = 'true'
    [10/29/15,10:29:14] Launching process 'Netfx40TestApplication.exe' now
    [10/29/15,10:29:14] Process successfully launched. Waiting 300 seconds for it to complete.
    [10/29/15,10:29:14] Process 'Netfx40TestApplication.exe' exited with return code 0
    [10/29/15,10:29:14] Verification succeeded for product .NET Framework 4 Full

    4 Client
    [10/29/15,10:29:50] Section [Registry - .NET Framework 4 Client (Wow6432Node)] - stop parsing entries
    [10/29/15,10:29:50] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [10/29/15,10:29:50] ExecutablePath = 'Netfx40TestApplication.exe'
    [10/29/15,10:29:50] FriendlyName = '.NET Framework 4 test application'
    [10/29/15,10:29:50] TimeoutSeconds = '300'
    [10/29/15,10:29:50] WaitOnExit = 'true'
    [10/29/15,10:29:50] Silent = 'true'
    [10/29/15,10:29:50] Launching process 'Netfx40TestApplication.exe' now
    [10/29/15,10:29:50] Process successfully launched. Waiting 300 seconds for it to complete.
    [10/29/15,10:29:50] Process 'Netfx40TestApplication.exe' exited with return code 0
    [10/29/15,10:29:50] Verification succeeded for product .NET Framework 4 Client

    windows installed_1

    windows installed_2

    -----

    Running CLVER.exe  ~ https://msdn.microsoft.com/en-us/library/ff427522(v=vs.110).aspx

    I got 

    result CLRVER






    • Edited by perezco Thursday, October 29, 2015 10:27 PM correction
    Thursday, October 29, 2015 4:05 PM
  • You have now demonstrated that your .NET Framework 4.0 through 4.6 is installed and configured correctly.

    If TOAD is having issues finding and using .NET 4.5.1 on a system with later updates installed (4.5.2 and 4.6), then you need to contact their support for assistance.

    The CLR version shows only the major versions, not updates.

    Am I misunderstanding your issue? To be honest, I'm confused by much of your second post (parts about uninstalling updates, etc.), as it appears that your issue has been shown not to be a .NET problem.

    • Proposed as answer by SimorC Thursday, October 29, 2015 10:30 PM
    Thursday, October 29, 2015 9:55 PM
  • It is  easy to state .NET 4.5, 4.51, 4.5.2  are "highly compatible" coming from the .net 4.6
    but the real true those version coming in this .net 4.6 packet are not going to have the same compatibility to the ones that had been made originally.

    What I will like to get response of what I asked at the beginning of the post...

    "Does Vstudio2013  will still working if I uninstall .Net framework 4.6. to be able to install  .Net framework 4.5.1  and then install back  .Net framework 4.6. ?"

     Does Visual studio 2013 ultimate with update 4 depends of Net 4.6?

    I tried already net 4.5.1 Developer Pack ...also no work

    In the second post I add a correction..in  { } 

    ...............
    by the moment sound like no 
    https://www.componentsource.com/product/microsoft-visual-studio-ultimate/compatibilities


    CRISTINA MICROSOFT Forum





    • Edited by perezco Thursday, October 29, 2015 10:41 PM details
    Thursday, October 29, 2015 10:23 PM
  • "Does Visual studio 2013 ultimate with update 4 depends of Net 4.6?"

    AFAIK, no. When VS 2013 was released, .NET 4.5.1 (released at the same time) came with it. I see no information on VS 2013 updates that changed the .NET version dependency of VS 2013.

    Friday, October 30, 2015 1:21 PM