locked
Creating Multiple Tasks Using A Replicator in WSS 3.0 RRS feed

  • Question

  • Hi All,

    I wanted to create multiple tasks using a replicator. I have followed Scott Hilllier's screencast (http://msdn.microsoft.com/en-us/library/hh128696.aspx) but it doesn't work for me. I'm not sure if his example would work on WSS 3.0 because his example shows Sharepoint 2010.

    I was able to follow his instructions creating a custom activity and creating a workflow with a replicator and add the custom activity. When I try to debug my workflow, it always give me a "Failed On Start (Retrying)" message.

    I am not sure if I did the custom activity correctly, but one thing to note though, I have made sure that the correlation token for all the objects in the custom activity are the same all throughout. Do I need to assign a unique TaskId for the createTask object and use that taskId for the other two objects (OnTaskChanged and completeTask) or the code in the createTask_MethodInvoking SPTaskId = Guid.NewGuid() will replace it? If it does, do I need to assign the taskId for the other two objects (OnTaskChanged and completeTask) to the variable SPTaskId?

    I'm already freshed out of ideas and just want to make this workflow work. Appreciate of any help!!!

    Thanks!

    Noynoy

     

    PS, I can send a copy of the project solution if anyone can help to examine it and make it work. Thanks!

    Thursday, December 15, 2011 9:35 AM

Answers

  • Can you look in the ULS log and include the complete stack trace. You should be able to debug the workflow using Visual Studio to see where it's failing.

    If you are creating high number of tasks then this might sometime fail, because the workflow transaction gets timed out.

    increase the default value of timeout ( default value is 1 min ). To do this, in the web.config file of the web application we need to set the default value to something more ( in this case its set to 30 mins )

    <configuration>
    <system.transactions>
    <defaultSettings timeout="00:30:00" />
    </system.transactions>
    </configuration>

    If you are still having issues with this and you cannot find an answer from the forum directly, please visit the link below to see the various paid support options available that may better meet your needs.

    http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

     

    Thanks, Manish

    Monday, December 19, 2011 11:09 PM