none
"Shared Folder" in "App for Office" is empty------Word Add-In office 2013 RRS feed

  • Question

  • i am using this link to made my first WordAddIn in Microsoft word 2013.

      WordAddIn=manifest.xml + web app

    After completing all steps i found out that Insert->AppforOffice->SharedFolder is empty.

    Any hint/suggestions regarding solution of this problem ??


    • Edited by arslan0tahir Wednesday, December 7, 2016 7:38 AM
    • Moved by Steve Fan Thursday, December 8, 2016 7:20 AM
    Wednesday, December 7, 2016 7:37 AM

All replies

  • Hi,

    Welcome to the Office 2013 and Office 365 ProPlus IT Pro General Discussions forum.

    This forum is for general question and feedback related to Office 2013 and Office 365 ProPlus. Since your question is more related to developing add-ins for Office, I'll move your question to the following dedicated forum:

    https://social.msdn.microsoft.com/Forums/office/en-US/home?forum=appsforoffice

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, December 8, 2016 7:19 AM
  • Hi arslan0tahir,

    As my experience, we could not set this shared address \\MyShare\boilerplate\home.html for SourceLocation, I suggest you try below manifest.

    <?xml version="1.0" encoding="UTF-8"?>
        <OfficeApp xmlns="http://schemas.microsoft.com/office/appforoffice/1.1"
                   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                   xsi:type="TaskPaneApp">
            <Id>2b88100c-656e-4bab-9f1e-f6731d86e464</Id>
            <Version>1.0.0.0</Version>
            <ProviderName>Microsoft</ProviderName>
            <DefaultLocale>en-US</DefaultLocale>
            <DisplayName DefaultValue="Boilerplate content" />
            <Description DefaultValue="Insert boilerplate content into a Word document." />
            <Hosts>
                <Host Name="Document"/>
            </Hosts>
            <DefaultSettings>
                <SourceLocation DefaultValue="https://www.google.com" />
            </DefaultSettings>
            <Permissions>ReadWriteDocument</Permissions>
        </OfficeApp>

    If add in shows up in Shared Folder, and you want to use your own web page, I suggest you host your web page on iis, and change the SourceLocation with IIS address.

    Best Regards,

    Edward


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, December 9, 2016 6:04 AM
  • well i hosted these three files on my sharepoint site but still no apps.

    1. Is it because i am using office 2013??
    2. Is it because i am using http instead of https??

    Rest i am all doing is according to this page "Build you first Word Add-In"

    Friday, December 9, 2016 6:49 AM
  • Hi arslan0tahir,

    Did my manifest work for you?

    You need to use https.

    Best Regards,

    Edward


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, December 9, 2016 9:02 AM
  • Hi arslan0tahir,

    Have your issue been resolved? If you have, I would suggest you mark the helpful reply as answer, if not, please feel free to let us know.

    Best Regards,

    Edward


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, December 23, 2016 5:54 AM