none
Can't integrate Sharepoint with Workflow service RRS feed

  • Question

  • Sorry!

    After googling a lot I can not find solution to my problem so decided to put my question here. I am receiving following error when try to run Register-SPWorkflowService -SPSite "https://webportal.domain.local" -WorkflowHostUri "https://wfserver.domain.local:12290/"

    Register-SPWorkflowService : The HTTP request has timed out after 200000 milliseconds.
    At line:1 char:1
    + Register-SPWorkflowService -SPSite "https://webportal.domain.local" -WorkflowHostUri "h ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidData: (Microsoft.Share...WorkflowService:RegisterSPWorkflowService) [Register-SPWorkflowService], TimeoutExcept
       ion
        + FullyQualifiedErrorId : Microsoft.SharePoint.WorkflowServices.PowerShell.RegisterSPWorkflowService

    When I saw ULS log it was showing following error

    06/25/2015 14:32:03.68    PowerShell.exe (0x4C38)    0x4D6C    SharePoint Server    Workflow Services    ahv85    Exception     System.TimeoutException: The HTTP

    request has timed out after 200000 milliseconds. ---> System.Net.WebException: The request was aborted: The request was canceled.     at

    System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)     at Microsoft.Workflow.Client.HttpGetResponseAsyncResult`1.OnGotResponse(IAsyncResult result)     

    --- End of inner exception stack trace ---     at Microsoft.Workflow.Common.AsyncResult.End[TAsyncResult](IAsyncResult result)     at

    Microsoft.Workflow.Client.HttpGetResponseAsyncResult`1.End(IAsyncResult result)     at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T

    content)     at Microsoft.Workflow.Client.WorkflowManagementClient.SendRequest[T](HttpWebRequest request, T content)     at

    Microsoft.Workflow.Client.ActivityManager.PublishInternal(ActivityDescriptionCollection activityCollection, Boolean validateOnly, Boolean terminateDependentInstances)  

       at Microsoft.SharePoint.WorkflowServices.StoreWorkflowDeploymentProvider.<>c__DisplayClassb.<UploadLocalActivities>b__9(ActivityBuilderAssemblyCollection

    collection, ActivityBuilderAssembly builderAssembly) StackTrace:  at Microsoft.Office.Server.Native.dll: (sig=a1000fac-02c7-4003-8d43-320bb54966b7|2|

    microsoft.office.server.native.pdb, offset=131D6) at Microsoft.Office.Server.Native.dll: (offset=21B79)    d7ec8b67-cbb0-4c2b-bd87-fdab7f52ebe7

    06/25/2015 14:32:03.68    PowerShell.exe (0x4C38)    0x4D6C    SharePoint Server    Workflow Services    ajlw5    Exception     System.TimeoutException: The HTTP

    request has timed out after 200000 milliseconds. ---> System.Net.WebException: The request was aborted: The request was canceled.     at

    System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)     at Microsoft.Workflow.Client.HttpGetResponseAsyncResult`1.OnGotResponse(IAsyncResult result)     

    --- End of inner exception stack trace ---     at Microsoft.Workflow.Common.AsyncResult.End[TAsyncResult](IAsyncResult result)     at

    Microsoft.Workflow.Client.HttpGetResponseAsyncResult`1.End(IAsyncResult result)     at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T

    content)     at Microsoft.Workflow.Client.WorkflowManagementClient.SendRequest[T](HttpWebRequest request, T content)     at

    Microsoft.Workflow.Client.ActivityManager.PublishInternal(ActivityDescriptionCollection activityCollection, Boolean validateOnly, Boolean terminateDependentInstances)  

       at Microsoft.SharePoint.WorkflowServices.StoreWorkflowDeploymentProvider.<>c__DisplayClassb.<UploadLocalActivities>b__9(ActivityBuilderAssemblyCollection

    collection, ActivityBuilderAssembly builderAssembly)     at Microsoft.SharePoint.WorkflowServices.StoreWorkflowDeploymentProvider.EnumerateBuilderAssemblies(Boolean

    sorted, BuilderAssemblySink sink) StackTrace:  at Microsoft.Office.Server.Native.dll: (sig=a1000fac-02c7-4003-8d43-320bb54966b7|2|microsoft.office.server.native.pdb,

    offset=131D6) at Microsoft.Office.Server.Native.dll: (offset=21B79)    d7ec8b67-cbb0-4c2b-bd87-fdab7f52ebe7

    06/25/2015 14:32:03.68    PowerShell.exe (0x4C38)    0x4D6C    SharePoint Foundation    PowerShell    6tf2    High    System.TimeoutException: The HTTP request has timed out

    after 200000 milliseconds. ---> System.Net.WebException: The request was aborted: The request was canceled.     at System.Net.HttpWebRequest.EndGetResponse

    (IAsyncResult asyncResult)     at Microsoft.Workflow.Client.HttpGetResponseAsyncResult`1.OnGotResponse(IAsyncResult result)     --- End of inner exception stack trace

    ---     at Microsoft.Workflow.Common.AsyncResult.End[TAsyncResult](IAsyncResult result)     at Microsoft.Workflow.Client.HttpGetResponseAsyncResult`1.End(IAsyncResult

    result)     at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)     at

    Microsoft.Workflow.Client.WorkflowManagementClient.SendRequest[T](HttpWebRequest request, T content)     at Microsoft.Workflow.Client.ActivityManager.PublishInternal

    (ActivityDescriptionCollection activityCollection, Boolean validateOnly, Boolean terminateDependentInstances)     at

    Microsoft.SharePoint.WorkflowServices.StoreWorkflowDeploymentProvider.<>c__DisplayClassb.<UploadLocalActivities>b__9(ActivityBuilderAssemblyCollection collection,

    ActivityBuilderAssembly builderAssembly)     at Microsoft.SharePoint.WorkflowServices.StoreWorkflowDeploymentProvider.EnumerateBuilderAssemblies(Boolean sorted,

    BuilderAssemblySink sink)     at Microsoft.SharePoint.WorkflowServices.StoreWorkflowDeploymentProvider.UploadLocalActivities(String serviceAddress, ICredentials

    workflowServiceCredentials, String activityName, Boolean force)     at

    Microsoft.SharePoint.WorkflowServices.PowerShell.RegisterSPWorkflowService.InternalProcessRecord()     at Microsoft.SharePoint.PowerShell.SPCmdlet.ProcessRecord()    

    d7ec8b67-cbb0-4c2b-bd87-fdab7f52ebe7

    I have made the setup account and service account both as computer administrator as well as work flow administrator. Both of these accounts are able to access workflow and sharepoint websites with out any error through https. I added service accounts to the user policy of all of my sharepoint web applications. giving it full control for all zones. My User profile service is showing the service and setup accounts. I have given sharepoint shall access rights to workflow admin group. setup account is same for both sharepoint and workflow. I am installing both sharepoint and workflow on a single machine.

    Any help would be a blessing for me


    Muhammad Masood

    Thursday, June 25, 2015 10:14 AM

Answers

  • At last I figured it out. I have to use Workflow Refresh and service bus 1.1. Then updated it to May 2015 Cumulative Update or latest one if you like. Re-provisioned the User Profile Service Application. Made sure that I have a web application without host header. Used a SSL with issue to "Web Application URL (computer-name.Apps-Domain)" with subject alternates having * or for all apps (*.Apps-Domain). Registered that SSL certificate as trusted root authority in SharePoint. As I was using single apps domain therefore disable multiple domain support. The followed Spencer Harbers instruction to install and configure the Workflow Manager. If you find any error then search through SharePoint logs using ULS viewer or anyother suitable tool. Bingo got it working.

    Muhammad Masood

    • Marked as answer by mushhuud Wednesday, August 26, 2015 8:43 AM
    Wednesday, August 26, 2015 8:43 AM

All replies

  • Any one from Microsoft please help.

    Muhammad Masood

    Tuesday, June 30, 2015 3:43 AM
  • I am using Windows 2012 r2. I have single SharePoint 2013 Server. Every thing is configured on this single server. "Azure Service Bus 1.1" and "Workflow Manager Refresh" both are also being installed on the same server using Web Platform installer 5.0. I have installed Cumulative update "May 2015". After installing CU, I have run the SP Configuration Wizard. When I run workflow configuration wizard using default setting, I also get a warning showing SSL Settings are deleted for 0.0.0.0:12290. I have tried using server name indication on all other websites with host header option but still no luck. Any on to rescue me. Its been long that I am struck in same error.

    Muhammad Masood

    Thursday, July 30, 2015 12:03 PM
  • At last I figured it out. I have to use Workflow Refresh and service bus 1.1. Then updated it to May 2015 Cumulative Update or latest one if you like. Re-provisioned the User Profile Service Application. Made sure that I have a web application without host header. Used a SSL with issue to "Web Application URL (computer-name.Apps-Domain)" with subject alternates having * or for all apps (*.Apps-Domain). Registered that SSL certificate as trusted root authority in SharePoint. As I was using single apps domain therefore disable multiple domain support. The followed Spencer Harbers instruction to install and configure the Workflow Manager. If you find any error then search through SharePoint logs using ULS viewer or anyother suitable tool. Bingo got it working.

    Muhammad Masood

    • Marked as answer by mushhuud Wednesday, August 26, 2015 8:43 AM
    Wednesday, August 26, 2015 8:43 AM