none
Migrate VHD doesn't work RRS feed

  • Question

  • We are testing FSLogix on a VMware Horizon environment and the VHD disks are created and everything seems to be working fine. We have defined a specific size for the VHDs, but as a precaution we need to ensure that in case if we need to increase the VHD disk size there is a way to do that. 

    1) Is there a supported way to increase the size of a VHD created by FSLogix? If yes, how?

    2) if the answer to the above is no, can we make use of migrate-vhd command to migrate the VHD contents to a larger disk and solve the above problem?

    I tried the migrate-vhd command, but it fails with the following error:

    ===================

    Waiting for volume arrival

    Destination VHD(X) does not exist.  Creating.
    Waiting for volume arrival
    .
    Formatting volume: \\?\Volume{24a68b70-62b2-4e5c-a804-a12eda28c896}\
    Mirroring directory:
    Source: C:\Users\<user>\AppData\Local\Temp\FrxSrcMigrate
    Dest: C:\Users\<user>\AppData\Local\Temp\FrxDestMigrate
    Volume root: \\?\Volume{24a68b70-62b2-4e5c-a804-a12eda28c896}\
    Attaching CldFlt to target volume
    Copying directory:
    Source: C:\Users\<user>\AppData\Local\Temp\FrxSrcMigrate
    Destination C:\Users\<user>\AppData\Local\Temp\FrxDestMigrate
    Copying directory: C:\Windows\system32\robocopy.exe "C:\Users\<user>\AppData\Local\Temp\FrxSrcMigrate" "C:\Users\<user>\AppData\Local\Temp\FrxDestMigrate" /B /MT /R:5 /W:1 /XJD /COPYALL /IT /DCOPY:DAT /MIR
    CreateProcess successful
    Enabling cloud files pass-through
    Waiting for process to end
                   Exit code: 9
    Unknown robocopy error: 0x00000009
    CopyDirectory error: 0x0000001D
    Error Mirroring files (0x0000001D): The system cannot write to the specified device.

    ===================

    If I create a VHD manually and do a migration, it works, but none of the VHDs created by FSLogix seems to be working. 

    Anybody has got any clue on what could be causing the above issue?

    Friday, July 31, 2020 6:09 AM

All replies

  • We're also currently testing FSLogix on our VMware Horizon environment.  I found during testing that only using the migrate-vhd command will result in unusable VHD.  The steps that worked for us are:

    1) create-vhd - manually create a new VHD

    2) migrate-vhd

    3) delete the original VHD

    4) rename the new VHD to the original name

    Tuesday, August 4, 2020 1:26 AM