locked
Not working well from vpn ssl RRS feed

  • Question

  • Hello,

    I have sharepoint 2010 fundation runing fine as a intranet and i also have an VPN SSL (barracuda) with a connection as a web forward to my intranet a can open the intranet login but in some tabs i can't edit or upload docs. The permissions are ok because from the inside everything works well.

    Any hints please

    Nuno

    Thursday, April 19, 2012 3:40 PM

Answers

All replies

  • Hi Nuno, sometimes this kind of problems are caused by a misconfiguration of AAM and Web Application extensions. I suggest to extend your web application and assign the https url to the extensions.

    Cheers
    Riccardo


    Italian SharePoint Community - My blog - My profile

    Thursday, April 19, 2012 3:45 PM
  • And do you use same name for accessing sharepoint internally and over VPN? including http:// or https:// prefix? Otherwise you have to configure alternate access mappings.

    Marek Chmel, WBI Systems (MCTS, MCITP, MCT, CCNA)
    Please Mark As Answer if my post solves your problem or Vote As Helpful if a post has been helpful for you.

    Thursday, April 19, 2012 5:32 PM
  • Hi,

    thanks for your help, i have an hadware VPN SSL from barracuda and i can access to sharepoint but cán't edit or upload any docs

    I am getting really anoyd because i have people that are using that equipment to access the intranet as is not working.

    Nuno 

    Friday, April 20, 2012 11:29 AM
  • Hello,

    thanks for your help, and yes i am using the same name

    Nuno

    Friday, April 20, 2012 11:30 AM
  • Hi Nuno, same name with different protocols? How do you configured Alternate Access Mappings in Central Administration?

    Regards
    Riccardo


    Italian SharePoint Community - My blog - My profile

    Friday, April 20, 2012 12:44 PM
  • Hi Ricardo,

    From inside i have to names one the machine name, and have an alias wich is intranet+domain.local

    From the SSL VPN i acess from the internet trought an adress vpn.mydomain.pt, and inside have a webforward to the sharepoint machinename.mydomain.local

    If it helps i can post an image off this.

    thanks

    Nuno

    Friday, April 20, 2012 1:28 PM
  • Hi Nuno,

    can you describe the configuration of the Alternate Access Mapping settings in SharePoint? You should have 3 entry for the web application, the default address (http://yourserver) , the intranet address (http://intranet.domain.local) and the extranet address (https://vpn.mydomain.pt).

    If you need more info here you can find a video how-to: http://technet.microsoft.com/en-us/sharepoint/Video/ff679917

    This article could also be useful http://technet.microsoft.com/en-us/library/cc261814.aspx. It's related to SharePoint 2007 but the most of the concepts are still applicable.

    Riccardo


    Italian SharePoint Community - My blog - My profile

    Friday, April 20, 2012 2:04 PM
  • Hi Ricardo,

    Thanks i will check the links.

    That adress VPN.mydomain.pt is an hadware SSL VPN witch does an inside my lan redirect, so the link that is configured in the SSL VPN is myserver.mydomain.local, and when you acess from outside trough the SSL VPN mos of the adresses are dealt ok, and are like this https://vpn.mydomain.pt/sharepoint directories....  but when i want to open or upload a file e solves that adress as http://myserver.mydomain.local/sharepoint directories....

    thanks

    Nuno

    Friday, April 20, 2012 2:25 PM
  • It seems that your problem falls into the topic convered in the the section "Reverse proxy publshing" http://technet.microsoft.com/en-us/library/cc261814.aspx#section2

    Cheers
    Riccardo


    Italian SharePoint Community - My blog - My profile

    Friday, April 20, 2012 9:30 PM